Bug 379431 - Malayalam rendered incorrectly in Mozilla Firefox
Malayalam rendered incorrectly in Mozilla Firefox
Status: CLOSED DUPLICATE of bug 242016
Product: Fedora
Classification: Fedora
Component: pango (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-13 00:58 EST by Manilal
Modified: 2007-11-30 17:12 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-14 07:33:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of Mozilla Firefox with http://ml.wikipedia.org (Fedora 7) (471.03 KB, image/png)
2007-11-13 00:58 EST, Manilal
no flags Details
Screenshot of Mozilla Firefox with http://ml.wikipedia.org (Fedora 8) (319.89 KB, image/png)
2007-11-13 01:00 EST, Manilal
no flags Details

  None (edit)
Description Manilal 2007-11-13 00:58:53 EST
Description of problem:
The Malayalam rendering in Mozilla Firefox is very bad when compared with Fedora
7. There are a couple of new issues in fedora 8. The chandrakala, chillus, etc
are incorrectly rendered.

Please compare the screenshots attached.

Version-Release number of selected component (if applicable):
pango-1.18.3-1.fc8
lohit-fonts-malayalam-2.1.5-3.fc8
fonts-malayalam-2.1.5-3.fc8
m17n-db-malayalam-1.4.0-6.fc8
m17n-contrib-malayalam-1.1.3-3.fc8

How reproducible:
Always

Steps to Reproduce:
1. Open http://ml.wikipedia.org in Mozilla Firefox
2. The title bar itself is incorrectly rendered.
3.
  
Actual results:
Please see the attachment : Screenshot-Fedora-8.png

Expected results:
Please see the attachment : Screenshot-Fedora-7.png (Not perfect)

Additional info:
Comment 1 Manilal 2007-11-13 00:58:53 EST
Created attachment 256391 [details]
Screenshot of Mozilla Firefox with http://ml.wikipedia.org (Fedora 7)
Comment 2 Manilal 2007-11-13 01:00:26 EST
Created attachment 256411 [details]
Screenshot of Mozilla Firefox with http://ml.wikipedia.org (Fedora 8)
Comment 3 Rajeesh 2007-11-13 05:16:30 EST
Replacing pango-indic-fc.so in '/usr/lib/pango/1.6.0/modules' directory in
Fedora 8 from the same file from '/usr/lib/pango/1.5.0/modules' directory
(pango-1.14.9) from RHEL5.1 solves the problem to some extent. It causes to
render Malayalam at least as good as in RHEL5.
Comment 4 Parag Nemade 2007-11-14 07:33:29 EST

*** This bug has been marked as a duplicate of 242016 ***

Note You need to log in before you can comment on or make changes to this bug.