Bug 379551 - firefox, -Os doesn't work on alpha...
firefox, -Os doesn't work on alpha...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
FF3RawhideClose
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-13 04:18 EST by Oliver Falk
Modified: 2007-12-20 11:46 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-20 11:46:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Sourceware 5276 None None None Never

  None (edit)
Description Oliver Falk 2007-11-13 04:18:45 EST
Please apply the following patch to the firefox.spec.
I'll try to fix the problem with upstream (gcc), as this seems to be a compiler
bug for me; First I thought it's relaxed binutils, but it wasn't...

Index: firefox.spec
===================================================================
RCS file: /cvs/pkgs/devel/firefox/firefox.spec,v
retrieving revision 1.207
diff -u -p -r1.207 firefox.spec
--- firefox.spec        5 Nov 2007 12:00:37 -0000       1.207
+++ firefox.spec        13 Nov 2007 09:16:54 -0000
@@ -196,7 +196,11 @@ removed in favor of xulrunner-devel.
 
 # Build with -Os as it helps the browser; also, don't override mozilla's warning
 # level; they use -Wall but disable a few warnings that show up _everywhere_
+%ifarch alpha
+MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %{__sed} -e 's/-Wall//')
+%else
 MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %{__sed} -e 's/-O2/-Os/' -e 's/-Wall//')
+%endif
 
 export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
 export PREFIX='%{_prefix}'
Comment 1 Christopher Aillon 2007-11-13 08:50:46 EST
I'd like to see what the gcc folks have to say about this before I add
workarounds for broken compilers.  Is there a gcc bug filed that I can reference?
Comment 2 Oliver Falk 2007-11-13 10:01:24 EST
I have not yet opened a bug against gcc. I only have the one against binutils.
I'll add a reference.
Comment 3 Matěj Cepl 2007-12-20 11:46:27 EST
We just updated the Firefox version in Fedora/development from 2.0 to a 3.0
pre-release version, which improves performance, memory usage, and fixes many
bugs and crashes.

Closing as CANTFIX since we aren't fixing bugs filed against 2.0 now that 3.0 is
in.  If this bug is still present in rawhide using a Firefox 3.0 version, please
re-open this bug.

Thanks and Happy Holidays

Note You need to log in before you can comment on or make changes to this bug.