Bug 379611 - Spare keystroke after switching to X
Summary: Spare keystroke after switching to X
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-13 09:45 UTC by Stepan Kasal
Modified: 2018-04-11 13:39 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-24 13:41:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg conf (435 bytes, text/plain)
2007-11-13 10:33 UTC, Stepan Kasal
no flags Details
x log (15.93 KB, text/plain)
2007-11-13 10:34 UTC, Stepan Kasal
no flags Details
/etc/sysconfig/keyboard (60 bytes, text/plain)
2007-11-14 17:05 UTC, Stepan Kasal
no flags Details
/lib/kbd/keymaps/ucw/cs-head.map.gz (1.39 KB, application/x-gzip)
2007-11-14 17:06 UTC, Stepan Kasal
no flags Details
/lib/kbd/keymaps/ucw/cs-ucw.map.gz (1.40 KB, application/x-gzip)
2007-11-14 17:06 UTC, Stepan Kasal
no flags Details

Description Stepan Kasal 2007-11-13 09:45:57 UTC
Description of problem:
<F12> in an active window

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.3.0.0-33.fc8.i386

How reproducible:
always

Steps to Reproduce:
My inittab contains mingetty lines for tty1 -- tty11, so X opens on tty12.
Initdefault is 3.
1. startx, open a terminal, vi, the 'i' to get to insert mode
2. ctrl-alt-F1 to get to the console
3. alt-F12 to get back to X
  
Actual results:
The string "<F12>" appears in the editor.
Should we have opened another program, we would see the function bound to F12 there.

Expected results:
No keystroke shall be delivered to the application.

I have a custom keybard driver on console, may that be the reason?
Hints for debugging this would be welcome.

Comment 1 Stepan Kasal 2007-11-13 10:33:37 UTC
Created attachment 256731 [details]
xorg conf

Comment 2 Stepan Kasal 2007-11-13 10:34:22 UTC
Created attachment 256741 [details]
x log

Comment 3 Matěj Cepl 2007-11-13 13:33:06 UTC
what kind of custom keyboard driver you have? Sorry, forgot to ask you in persona.

Comment 4 Stepan Kasal 2007-11-14 17:05:43 UTC
Created attachment 258391 [details]
/etc/sysconfig/keyboard

Comment 5 Stepan Kasal 2007-11-14 17:06:29 UTC
Created attachment 258411 [details]
/lib/kbd/keymaps/ucw/cs-head.map.gz

Comment 6 Stepan Kasal 2007-11-14 17:06:50 UTC
Created attachment 258421 [details]
/lib/kbd/keymaps/ucw/cs-ucw.map.gz

Comment 7 Stepan Kasal 2007-11-14 17:07:28 UTC
see comments 4--6

Comment 8 Bug Zapper 2008-05-14 03:52:38 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 9 Peter Hutterer 2008-10-13 06:22:46 UTC
Stephan: do you still have this issue with the current version in F9?
I can't reproduce it, at least not with VT7. 

If you still experience this issue, can you please attach the out.xkb file after running "xkbcomp -xkb :0 out.xkb". thanks.

Comment 10 Stepan Kasal 2008-11-24 13:41:25 UTC
Peter: you are right, after "yum update 'xorg*'", the bug disappeared.

Sorry that my reaction is so late, and thank you for your work!


Note You need to log in before you can comment on or make changes to this bug.