Bug 379651 - toshiba laptop: Timer interrupt error on reboot
toshiba laptop: Timer interrupt error on reboot
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-13 05:29 EST by Derkjan de Haan
Modified: 2008-08-07 11:46 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.6.23.14-115.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-07 19:33:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Derkjan de Haan 2007-11-13 05:29:36 EST
Description of problem:

During a reboot, the following BIOS message is displayed: "Timer interrupt 
error".
The system then reboots and appears to behave normally, but it hangs during 
startup, after the message "Uncompressing Linux... Ok, booting the kernel"

Version-Release number of selected component (if applicable):

Linux toshiba.badmuts.org 2.6.23.1-49.fc8 #1 SMP Thu Nov 8 21:41:26 EST 2007 
i686 i686 i386 GNU/Linux
System is a Toshiba Satellite Pro 2100 laptop (the same hardware has been sold 
earlier as the Toshiba Satellite 2410 series). Intel Celeron CPU 1500 MHz, 
Intel chipset. System is a 3-4 years old IIRC.

How reproducible:

Always

Steps to Reproduce:
1. Reboot and observe
2.
3.
  
Additional info:

This started happening after I upgraded from F7 to F8.
Please let me know if I can assist in any way.
Comment 1 Mace Moneta 2007-11-19 17:12:06 EST
I'm seeing the same thing on two Toshiba 5105-s607.  They used to run FC6 with
no error on reboot.  With F8, this error appears requiring a power cycle for a
successful boot.
Comment 2 Mace Moneta 2007-11-19 17:32:44 EST
I just ran some reboot testing, and found that I can prevent the error by
booting with kernel parameter:

clocksource=pit

Of course, wakeups per second went from about 200 to 1000.  I tried hpet with
hires=off, and that had no effect on the timer error.  Nor did acpi_pm.
Comment 3 Christopher Brown 2008-02-07 14:12:19 EST
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. This should now be
resolved - can you verify with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.
Comment 4 Derkjan de Haan 2008-02-07 14:39:32 EST
Yes, for me it's solved with the latest kernel. I kind of noticed it by 
accident though, because nothing in the kernel changelog indicated there had 
been fixes in this area.
Comment 5 Mace Moneta 2008-02-07 15:00:11 EST
Confirming; booting 2.6.23.14-115.fc8 without clocksource=pit no longer causes a
problem.

I'd like to second that it would be nice if the changelog referenced bugs that
were thought to be fixed, as I also missed that this was the case in the current
kernel.  

There was no package announcement for this kernel either - I had to check koji
for the changelog.
Comment 6 andrew jarcho 2008-08-07 11:46:26 EDT
I'm getting the same behavior on reboot ("timer interrupt error" message, then a hang after the message "Uncompressing Linux... Ok, booting the kernel"). After a cold boot, though, the system behaves normally.

The kernel is 2.6.25.11-60 fc8 running on a Toshiba A45-S250 with a brand new hard drive. fc8 is the only OS on this machine.

Note You need to log in before you can comment on or make changes to this bug.