Bug 379761 - add nxserver logrotate file
add nxserver logrotate file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: freenx (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Jon Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-13 07:01 EST by Helge Deller
Modified: 2007-12-07 16:31 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.7.1-2.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-07 16:31:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Helge Deller 2007-11-13 07:01:58 EST
It would be nice, if the nxserver log file (/var/log/nxserver.log) could be 
added to the logrotate functionality, since it grows by ~1.7MB per day in our 
usage.

We created the new file "/etc/logrotate.d/nx" with the following content:
/var/log/nxserver.log {
    rotate 4
    size=10M
    notifempty
    missingok
    sharedscripts
    copytruncate
}

After that, the log file is nicely rotated.

Could you please add this file (or a similiar one) to the freenx-0.7.0-2.fc7 
rpm package ?
Comment 1 Jon Ciesla 2007-11-19 08:53:29 EST
New rawhide version has this.  Will work back down to 8, 7, 6, soon.
Comment 2 Helge Deller 2007-11-19 10:16:43 EST
Hi Jon,
Thanks !
I think you can even reduce the sie to "size=4MB". Makes it easier and faster 
to read the files with "vi".
Regards, Helge
Comment 3 Jon Ciesla 2007-11-19 10:41:35 EST
Oops, hadn't actually imported and built that change.  0.7.1-2 has this. :)
Comment 4 Fedora Update System 2007-12-07 16:31:05 EST
freenx-0.7.1-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.