Bug 379941 - rpc.mountd dies with SIGFPE
rpc.mountd dies with SIGFPE
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: e2fsprogs (Show other bugs)
8
i686 Linux
low Severity high
: ---
: ---
Assigned To: Eric Sandeen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-13 08:11 EST by Alexander Lukyanov
Modified: 2007-12-10 09:46 EST (History)
1 user (show)

See Also:
Fixed In Version: e2fsprogs-libs-1.40.2-11.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-10 08:45:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for libblkid probe.c (362 bytes, patch)
2007-11-13 16:19 EST, Alexander Lukyanov
no flags Details | Diff
first 1k of hdf1 (1.00 KB, application/octet-stream)
2007-12-10 09:46 EST, Alexander Lukyanov
no flags Details

  None (edit)
Description Alexander Lukyanov 2007-11-13 08:11:47 EST
Description of problem:
rpc.mountd dies with SIGFPE

Version-Release number of selected component (if applicable):
nfs-utils-1.1.0-6.fc8

How reproducible:
always

Steps to Reproduce:
1. rpc.mountd dies with SIGFPE on a lvm2 400 Gb volume

Actual results:
   strace of rpc.mountd:
stat64("/dev/hdf1", {st_mode=S_IFBLK|0640, st_rdev=makedev(33, 65), ...}) = 0
time(NULL)                              = 1194952068
open("/dev/hdf1", O_RDONLY)             = 12
fstat64(12, {st_mode=S_IFBLK|0640, st_rdev=makedev(33, 65), ...}) = 0
uname({sys="Linux", node="backup", ...}) = 0
ioctl(12, BLKGETSIZE64, 0xbfac1dd8)     = 0
_llseek(12, 80023650304, [80023650304], SEEK_SET) = 0
read(12, "\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0"...,
4096) = 4096
brk(0x8006c000)                         = 0x8006c000
lseek(12, 0, SEEK_SET)                  = 0
read(12,
"\353<\0\0\0\0\0\0\0\0\0\0\2\0\0\0\0\0\0\0\0\0\0\0\22\0\2\0\0\0\0\0"..., 69632)
= 69632
--- SIGFPE (Floating point exception) @ 0 (0) ---

Expected results:

Additional info:
I use lvm2, and hdf1 is a pv, part of an exported filesystem. The filesystem is
400 Gb, if that matters.
Comment 1 Steve Dickson 2007-11-13 11:10:28 EST
Is SELinux in the picture?
Comment 2 Alexander Lukyanov 2007-11-13 15:41:03 EST
No, selinux is disabled.

It seems the problem is inside of libblkid:

#0  0xb7fb8ca5 in ?? () from /lib/libblkid.so.1
#1  0xb7fb96c0 in blkid_verify () from /lib/libblkid.so.1
#2  0xb7fb6808 in blkid_get_dev () from /lib/libblkid.so.1
#3  0xb7fb6a3f in ?? () from /lib/libblkid.so.1
#4  0xb7fb75f5 in ?? () from /lib/libblkid.so.1
#5  0x80005c4e in ?? () from /usr/sbin/rpc.mountd
#6  0x80006022 in ?? () from /usr/sbin/rpc.mountd
#7  0x800060c0 in ?? () from /usr/sbin/rpc.mountd
#8  0x8000638b in ?? () from /usr/sbin/rpc.mountd
#9  0x80002f51 in ?? () from /usr/sbin/rpc.mountd
#10 0x8000315f in ?? () from /usr/sbin/rpc.mountd
#11 0x8000d802 in ?? () from /usr/sbin/rpc.mountd
#12 0x800044cc in mount_dispatch () from /usr/sbin/rpc.mountd
#13 0xb7f56642 in svc_getreq_common_internal () from /lib/libc.so.6
#14 0xb7f55f31 in svc_getreqset_internal () from /lib/libc.so.6
#15 0x8000747d in ?? () from /usr/sbin/rpc.mountd
#16 0x80004044 in main () from /usr/sbin/rpc.mountd
Comment 3 Alexander Lukyanov 2007-11-13 16:19:00 EST
Created attachment 257441 [details]
patch for libblkid probe.c

This patch fixes the problem, which was division by zero cluster_size.
Comment 4 Eric Sandeen 2007-11-30 10:32:30 EST
Looks like probably a dup of bug #398281

Can you please test:

https://admin.fedoraproject.org/updates/F8/FEDORA-2007-3853

Thanks,
-Eric
Comment 5 Eric Sandeen 2007-11-30 10:35:14 EST
btw what is actually on /dev/hdf1?

Thanks,
-Eric
Comment 6 Alexander Lukyanov 2007-12-10 07:23:21 EST
e2fsprogs-libs-1.40.2-11.fc8 fixes the problem for me.

/dev/hdf1 is a part of logical volume, it does not have a filesystem superblock
in the beginning. I wonder why rpc.mountd tries to determine filesystem type of it.
Comment 7 Eric Sandeen 2007-12-10 08:45:15 EST
Thanks for testing the latest release.  If you want to dd off the first 1k or so
of /dev/hdf1 and attach, I can try to find some time to look at it.  It may have
an old signature on it...
Comment 8 Alexander Lukyanov 2007-12-10 09:46:20 EST
Created attachment 282831 [details]
first 1k of hdf1

Note You need to log in before you can comment on or make changes to this bug.