Bug 37996 - hdlist2 not found in local-disk upgrade of 7.0
hdlist2 not found in local-disk upgrade of 7.0
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
: 39069 50072 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-27 02:24 EDT by Matthew Costello
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-04 10:56:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda dump text (10.11 KB, text/plain)
2001-04-27 02:26 EDT, Matthew Costello
no flags Details

  None (edit)
Description Matthew Costello 2001-04-27 02:24:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3 i686)


Doing an upgrade of 7.0 using boot.img and iso images on /dev/sdb1 fails
with an anaconda error and a python stack trace.
  OSError: [Errno 2] No such file or directory:
'/tmp/hdimage//RedHat/base/hdlist2'
Machine is dual PIII with aic7xxx SCSI disks.

Reproducible: Didn't try
Steps to Reproduce:
1.seawolf iso images on second SCSI disk, boot using 'boot.img'
2.select "local disk" and upgrade
3.save "anacdump.txt" (973 lines) to floppy
	

Actual Results:  Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 520, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/text.py", line 1126, in run
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/textw/upgrade_text.py",
line 33, in __call__
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1224, in
upgradeFindPackages
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/harddrive.py", line 182, in
mergeFullHeaders
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/comps.py", line 122, in
mergeFullHeaders
OSError: [Errno 2] No such file or directory:
'/tmp/hdimage//RedHat/base/hdlist2'

Local variables in innermost frame:
self: <comps.HeaderListFromFile instance at 833a4e8>
file: /tmp/hdimage//RedHat/base/hdlist2

...
Comment 1 Matthew Costello 2001-04-27 02:26:28 EDT
Created attachment 16585 [details]
anaconda dump text
Comment 2 Brent Fox 2001-04-27 09:06:06 EDT
Have you checked the md5sums of the ISOs?  I think you might have gotten a bad
download.
Comment 3 Matthew Costello 2001-04-27 13:32:51 EDT
The md5sums are fine.  They are:

596b1575773e88e066326f6741312a6f  seawolf-i386-disc1.iso
f27b912299572a542cd663b712444445  seawolf-i386-disc2.iso
Comment 4 Brent Fox 2001-05-01 16:23:30 EDT
In the installer, can you go to VC2 and type 'ls -l
/tmp/hdimage/RedHat/base/hdlist2' and see if the file is there.  If it is there,
what is the size of it?
Comment 5 Matthew Costello 2001-05-03 23:02:42 EDT
Used VC2 to look at /tmp/hdimage and found that anaconda had decided to mount
the Guinness (7.0) CD image instead of Seawolf (7.1).  The workaround is
obvious...

Anaconda is already mounting lots of CD images looking for the right ISO image.
It should probably be modified to verify that it has mounted the correct
version.

p.s. Another minor bug found.  The install claimed I did not not have enough
disk space to upgrade all the packages, so I used VC2 to free a lot of space on
the root filesystem and selected BACK. Upon selecting OK from the "install
packages" menu the second time I got the error:
	System Error: Trying to mount already-mounted iso image!
and worse, it left the my HDs mounted at the "reboot system" prompt so all my
filesystems were dirty.
Comment 6 Brent Fox 2001-05-04 10:56:18 EDT
We will consider the idea of trying to verify that the iso image mounted is the
right one.  Thanks for your report.
Comment 7 Brent Fox 2001-05-04 11:28:11 EDT
*** Bug 39069 has been marked as a duplicate of this bug. ***
Comment 8 Brent Fox 2001-07-26 11:12:36 EDT
*** Bug 50072 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.