This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 37997 - X starts fine, but after a couple seconds the screen goes blank. Cirrus CL-GD5446
X starts fine, but after a couple seconds the screen goes blank. Cirrus CL-GD...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-27 02:36 EDT by Per Bjorlo
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-07 02:31:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Configuration file (1.78 KB, text/plain)
2001-04-27 06:10 EDT, Per Bjorlo
no flags Details
Log file (the only one I get) (20.31 KB, text/plain)
2001-04-27 06:11 EDT, Per Bjorlo
no flags Details

  None (edit)
Description Per Bjorlo 2001-04-27 02:36:30 EDT
When starting X (with startx), I can see the initial 'hashed' background with the X-shaped cursor. After a couple of seconds the screen goes 
blank. I can hear that KDE2 probably is loading, because you can hear the start-up tune playing. I'm using a plain 7.1 release with the shipped 
XFree86. The graphics card is an Cirrus CL-GD5446 with 2 Mb of video memory.
Comment 1 Per Bjorlo 2001-04-27 06:10:03 EDT
Created attachment 16625 [details]
Configuration file
Comment 2 Per Bjorlo 2001-04-27 06:11:44 EDT
Created attachment 16626 [details]
Log file (the only one I get)
Comment 3 Alexei Podtelezhnikov 2001-04-27 12:46:05 EDT
I know that DRI will not work on your card with this resolution because of lack 
of videoram. You may try to get it to work at 640x480x16bpp, or disable it 
altogether. Your log file doesn't show it's being enabled anyway. It's neither 
anaconda nor Xconfigurator who produced this config. What did you use? Last 
thing (probably first), try to reproduce it with lower resolution starting with 
mentioned above. 

and wait what Mike has to tell you :)
Comment 4 Mike A. Harris 2001-05-06 17:09:06 EDT
Mike says "Cirrus Logic GL5446 is not a 3D card, and is definitely not
supported by DRI".  ;o)

Comment out the DRI section at the bottom, and also comment out the
Load "dri" line at the top of the file, and see if it makes any difference.

If that doesn't work, try "Xconfigurator --preferxf4" to reconfigure X, as
Anaconda might have generated a bogus file.  If that still doesn't help...
try changing your bit depth to 24 instead of 16.  A 2Mb card should
support 1024x768x24 ok.  If that doesn't work, try changing to GNOME desktop
just for the purposes of testing/elimination.  From the commandline type
"switchdesk gnome" then startx up.  Does GNOME start ok?  If not, then it is
something KDE is doing during startup that is killing X (and is likely an X
bug).  I've CC'd Bero in case he has any datapoints to add from the KDE
viewpoint.

If all else fails, try "Xconfigurator --preferxf3".  Does it work?


Comment 5 Per Bjorlo 2001-05-07 02:28:49 EDT
Removing the dri module did the thing. Now everything works fine (XF4 does not support accelerated graphics though). I can even get Xconfigurator to 
work when using the --nodri option, it coredumps without it.

Tanks for the help.

Note You need to log in before you can comment on or make changes to this bug.