Bug 380 - Apache 403 Forbidden on /home Symlink
Summary: Apache 403 Forbidden on /home Symlink
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: apache   
(Show other bugs)
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-12-10 16:27 UTC by harterd
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1998-12-10 16:58:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description harterd 1998-12-10 16:27:18 UTC
I have /home symlinked to /usr/home, and all pages were
"403 Forbidden".  After changing access.conf:

<Directory />
#Options None
Options FollowSymLinks
AllowOverride None
</Directory>

Things now work.  Was this the proper change?  Should I have
changed the directory from / to /usr?  Maybe a change in the
RPM to check for symlinks on /home would be a good idea?

Thanks.

Dan Harter

Comment 1 David Lawrence 1998-12-10 16:58:59 UTC
You alleviated the problem correctly. This is not a change for the rpm
package as much as just a apache configuration issue. Although it is
probably better to leave only /home accessible from outside due to
possible security concerns with having / as being open.


Note You need to log in before you can comment on or make changes to this bug.