Bug 38011 - bind-9.1.0-10 rpm doesn't enforce kernel dependency
bind-9.1.0-10 rpm doesn't enforce kernel dependency
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: bind (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-27 03:26 EDT by Curtis Doty
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-27 14:24:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Curtis Doty 2001-04-27 03:26:01 EDT
It appears this rpm does not check for the presense of kernel 2.4, thus 
allowing me to install with kernel 2.2. Yet it gets rather grumpy due to 
the use of -u in the init script.
Comment 1 Daniel Roesen 2001-04-27 04:49:51 EDT
There is no problem with using -u with current 2.2 kernels. The only problem I
saw was that BIND disables IPv6 because it detects kernel<->libc structure
discrepancies.
Comment 2 Curtis Doty 2001-04-27 13:42:24 EDT
My config...

$ rpm -q kernel bind bind-utils
kernel-2.2.16-22
bind-9.1.0-10
bind-utils-9.1.0-10

and from the syslog:
named: named startup succeeded
named[2203]: starting BIND 9.1.0
named: named:
named: -u not supported on Linux kernels older than 2.3.99-pre3 when using 
threads
named: named startup failed

Workaround was hack -u out of the init script, change some permissions, and run 
as root. Ugh!
Comment 3 Daniel Roesen 2001-04-27 13:56:59 EDT
I said "with current 2.2 kernels" which 2.2.16 doesn't qualify as. IIRC the
change is in 2.2.18 or at least 2.2.19.
Comment 4 Curtis Doty 2001-04-27 14:24:36 EDT
I'm stuck with 2.2.16 due to the !%$! closed source module for a Promise 
FastTrak controller. However, I would have avoided this had the specfile 
included a Requires: kernel >= 2.2.18
Comment 5 Bernhard Rosenkraenzer 2001-04-27 17:42:30 EDT
We don't want the dependency in precisely because you can run without "-u 
named".

You should really really update to kernel 2.2.18 or higher though, 2.2.18 
fixes a local root exploit.
Since there are not that many changes between 2.2.16 and 2.2.19, are you sure 
you can't just insmod -f their module?


Note You need to log in before you can comment on or make changes to this bug.