Bug 38011 - bind-9.1.0-10 rpm doesn't enforce kernel dependency
Summary: bind-9.1.0-10 rpm doesn't enforce kernel dependency
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bind
Version: 7.1
Hardware: i386
OS: Linux
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
Depends On:
TreeView+ depends on / blocked
Reported: 2001-04-27 07:26 UTC by Curtis Doty
Modified: 2007-04-18 16:32 UTC (History)
1 user (show)

Clone Of:
Last Closed: 2001-04-27 18:24:40 UTC

Attachments (Terms of Use)

Description Curtis Doty 2001-04-27 07:26:01 UTC
It appears this rpm does not check for the presense of kernel 2.4, thus 
allowing me to install with kernel 2.2. Yet it gets rather grumpy due to 
the use of -u in the init script.

Comment 1 Daniel Roesen 2001-04-27 08:49:51 UTC
There is no problem with using -u with current 2.2 kernels. The only problem I
saw was that BIND disables IPv6 because it detects kernel<->libc structure

Comment 2 Curtis Doty 2001-04-27 17:42:24 UTC
My config...

$ rpm -q kernel bind bind-utils

and from the syslog:
named: named startup succeeded
named[2203]: starting BIND 9.1.0
named: named:
named: -u not supported on Linux kernels older than 2.3.99-pre3 when using 
named: named startup failed

Workaround was hack -u out of the init script, change some permissions, and run 
as root. Ugh!

Comment 3 Daniel Roesen 2001-04-27 17:56:59 UTC
I said "with current 2.2 kernels" which 2.2.16 doesn't qualify as. IIRC the
change is in 2.2.18 or at least 2.2.19.

Comment 4 Curtis Doty 2001-04-27 18:24:36 UTC
I'm stuck with 2.2.16 due to the !%$! closed source module for a Promise 
FastTrak controller. However, I would have avoided this had the specfile 
included a Requires: kernel >= 2.2.18

Comment 5 Bernhard Rosenkraenzer 2001-04-27 21:42:30 UTC
We don't want the dependency in precisely because you can run without "-u 

You should really really update to kernel 2.2.18 or higher though, 2.2.18 
fixes a local root exploit.
Since there are not that many changes between 2.2.16 and 2.2.19, are you sure 
you can't just insmod -f their module?

Note You need to log in before you can comment on or make changes to this bug.