Bug 380231 - F8 (and later updates of F7) will not boot/install on Abit An52 motherboard
F8 (and later updates of F7) will not boot/install on Abit An52 motherboard
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-11-13 10:45 EST by Doug McLaren
Modified: 2007-12-04 15:52 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-12-04 15:52:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
dmesg, lsmod, lspci, etc. output from the last _working_ kernel. (14.39 KB, application/octet-stream)
2007-11-13 10:45 EST, Doug McLaren
no flags Details

  None (edit)
Description Doug McLaren 2007-11-13 10:45:13 EST
I've got an Abit An52 motherboard with the latest (2007/08/02) BIOS
installed.  It's got three SATA drives, using the internal SATA controllers
and four PATA drives, using a cheap ATA raid card to connect those to.
DVD drive is on the built-in PATA connector.

It boots off the first SATA drive.

The only options the BIOS has related to the mode that the SATA controllers use
gives you the choice of IDE and RAID, and I have the computer in IDE mode, but
RAID mode doesn't change anything.

The computer runs fine on Fedora 7, which it currently has installed,
running 2.6.21-1.3194.fc7.  However, this is the last kernel that has worked
-- and fail to boot, as it loads the kernel
and then can't access the (SATA) disk and panics.  It does hang a long time
during boot as it tries to access each SATA disk, printing messages such as --
`qc timeout' `failed to IDENTIFY' `port is slow to respond, please be patient'.

With the F8 x86_64 disk, it spends a very long time trying to load the
ahci driver and doesn't find the disk and eventually says it can't find a
disk to install on (which surprises me, it ought to at least find the
Promise 100TX2 raid card and it's drives, though I don't want to install on

The computer does not have a serial port (grrr!) so I can't easily capture
the kernel output.  Perhaps via a live CD, if I need to try that.  I have
included a bunch of information (dmesg, lsmod, lspci, etc.) collected under
the 2.6.21-1.3194.fc7 kernel -- which is the one that works.

I've looked online for other reports of the same problem, and really haven't
found anything -- which surprises me.  The most useful looking thing I found
was this at forum.abit-usa.com/showthread.php?p=873072 --

I think I know what's going on here, the drivers labeled 'sata-ide' in nforce520
(mcp65) package are actually for an AHCI controller, with device_id 044D. Even
though an52 specs show it as an nforce520 board, the sata chip (or atleast the
bios) doesn't support AHCI, only Raid (044C) & Ide (045D) modes . One might
confuse sata-ide mode for ahci (as I did) but really this is just Legacy IDE
emulation, with no support for sata features like only UDMA-5 (100MB/s instead
of ~300MB/s ), no NCQ, no hotplug, etc, etc. Needless to say, this is awful.

I wonder, does Abit have any NForce 5 mboard supporting ahci/sata-ide, or are
they all crippled like this one ?

... but I don't know if that's relevant or not.  Either way, older kernels
do work just fine, and the SATA drives even performs well.
Comment 1 Doug McLaren 2007-11-13 10:45:13 EST
Created attachment 256981 [details]
dmesg, lsmod, lspci, etc. output from the last _working_ kernel.
Comment 2 Doug McLaren 2007-11-13 10:51:36 EST
The computer and currently working kernel also seems to have the issue mentioned
in buzilla 247353, but so far it seems completely harmless -- it's had it for
months and it seems to have no ill effects.
Comment 3 Doug McLaren 2007-11-13 22:33:17 EST
Adding `pci=nomsi' to the kernel options seems to have made the later F7 kernels
work.  I'll try it with the F8 install DVD soon ...
Comment 4 Doug McLaren 2007-12-03 14:15:38 EST
And pci=nomsi worked for installing F8 too.  So this can probably be marked as
Comment 5 Chuck Ebbert 2007-12-04 15:52:47 EST
Works with pci=nomsi workaround.

Note You need to log in before you can comment on or make changes to this bug.