Bug 380241 - compiz breakage with fc9 packages
compiz breakage with fc9 packages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-13 10:52 EST by Tom London
Modified: 2008-08-02 19:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-12 17:15:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2007-11-13 10:52:52 EST
Description of problem:
mesa*7.1-0.3.fc9.i386 packages break compiz for me.

I get this in .xsession-errors:
SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/29072,unix/unix:/tmp/.ICE-unix/29072
compiz (core) - Fatal: No GLXFBConfig for default depth, this isn't going to work.
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0
seahorse nautilus module initialized
Initializing gnome-mount extension

** (nautilus:29221): WARNING **: Can not calculate _NET_NUMBER_OF_DESKTOPS

** (nautilus:29221): WARNING **: Can not calculate _NET_NUMBER_OF_DESKTOPS

** (nautilus:29221): WARNING **: Can not get _NET_WORKAREA

** (nautilus:29221): WARNING **: Can not determine workarea, guessing at layout
start time: Tue Dec 26 06:00:00 2006

Reverting to 7.0.1-7.fc8 'makes it work'.


Version-Release number of selected component (if applicable):
7.1-0.3.fc9

How reproducible:
every time.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2007-11-15 10:50:03 EST
On additional testing, I think this pointing to mesa is probably bogus.

I'll file something against compiz.
Comment 2 Tom London 2007-11-15 18:03:01 EST
Redirecting this against compiz.

I understand lots of things are changing; just want to make sure this doesn't
get lost.

Compiz on Thinkpad X60 no longer works with rawhide packages (except for gdm).

Get this from compiz-manager:

[tbl@localhost ~]$ compiz-manager
Checking for Xgl: not present. 
Detected PCI ID for VGA: 00:02.0 0300: 8086:27a2 (rev 03) (prog-if 00 [VGA])
Checking for texture_from_pixmap: present. 
Checking for non power of two support: present. 
Checking for Composite extension: present. 
Comparing resolution (1280x1024) to maximum 3D texture size (2048): Passed.
Checking for nVidia: not present. 
Checking for FBConfig: present. 
Checking for Xgl: not present. 
Starting gtk-window-decorator
/usr/bin/compiz (core) - Fatal: No GLXFBConfig for default depth, this isn't
going to work.
/usr/bin/compiz (core) - Error: Failed to manage screen: 0
/usr/bin/compiz (core) - Fatal: No manageable screens found on display :0.0

/var/log/Xorg.0.log has this:

drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (No such file or directory)
drmOpenDevice: Open failed
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (No such file or directory)
drmOpenDevice: Open failed
drmOpenByBusid: Searching for BusID pci:0000:00:02.0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (No such file or directory)
drmOpenDevice: Open failed
drmOpenByBusid: drmOpenMinor returns -2
drmOpenDevice: node name is /dev/dri/card1
drmOpenDevice: open result is -1, (No such file or directory)
drmOpenDevice: Open failed
drmOpenByBusid: drmOpenMinor returns -2
drmOpenDevice: node name is /dev/dri/card2
<<<SNIP>>>
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (No such file or directory)
drmOpenDevice: Open failed
(EE) [drm] drmOpen failed.
(EE) intel(0): [dri] DRIScreenInit failed. Disabling DRI.

Disabling compiz (and/or running metacity) works fine.
Comment 3 Tom London 2008-02-11 18:13:23 EST
compiz works with kernel-2.6.24.1-28.fc9.i686 !!!!

Am testing it now, but wobbly windows, cube, etc. seem to work on Thinkpad X60.
Comment 4 Matěj Cepl 2008-02-12 17:11:54 EST
OK, could we close this bug as CLOSED/RAWHIDE, please?

Note You need to log in before you can comment on or make changes to this bug.