Bug 380301 - xmlto fails to convert a even a simple (valid) xml file to PDF
xmlto fails to convert a even a simple (valid) xml file to PDF
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xmlto (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-13 11:14 EST by milady
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-28 18:29:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
simple xml file (328 bytes, text/xml)
2007-11-13 11:14 EST, milady
no flags Details

  None (edit)
Description milady 2007-11-13 11:14:28 EST
Description of problem:
xmlto fails to convert a even a simple (valid) xml file to PDF.

Version-Release number of selected component (if applicable):
xmlto-0.0.18-17
xmltex-20020625-8
passivetex-1.25-5.1.1

How reproducible:
Always

Steps to Reproduce:
1. execute xmlto pdf simple.pdf
2.
3.
  
Actual results:
xmlto crashes and does not create the pdf file. See output below:

$ xmlto pdf simple.xml
Making portrait pages on USletter paper (8.5inx11in)
This is pdfTeXk, Version 3.141592-1.40.3 (Web2C 7.5.6)
 %&-line parsing enabled.
entering extended mode
(./tmp.fo
LaTeX2e <2005/12/01>
Babel <v3.8h> and hyphenation patterns for english, usenglishmax, dumylang, noh
yphenation, arabic, basque, bulgarian, coptic, welsh, czech, slovak, german, ng
erman, danish, esperanto, spanish, catalan, galician, estonian, farsi, finnish,
 french, greek, monogreek, ancientgreek, croatian, hungarian, interlingua, ibyc
us, indonesian, icelandic, italian, latin, mongolian, dutch, norsk, polish, por
tuguese, pinyin, romanian, russian, slovenian, uppersorbian, serbian, swedish,
turkish, ukenglish, ukrainian, loaded.
xmltex version: 2002/06/25 v1.9 (Exp):
(/opt/texlive/2007/../texmf-local/tex/xmltex/xmltex.cfg)
No File: tmp.cfg
(/opt/texlive/2007/../texmf-local/tex/xmltex/passivetex/fotex.xmt)
(/opt/texlive/2007/texmf-dist/tex/latex/base/article.cls
Document Class: article 2005/09/16 v1.4f Standard LaTeX document class
(/opt/texlive/2007/texmf-dist/tex/latex/base/size10.clo))
(/opt/texlive/2007/../texmf-local/tex/xmltex/passivetex/fotex.sty
)
No file tmp.aux.
(/opt/texlive/2007/texmf-dist/tex/latex/tipa/t3ptm.fd)
(/opt/texlive/2007/texmf-dist/tex/latex/cyrillic/t2acmr.fd)
(/opt/texlive/2007/texmf-dist/tex/latex/base/ts1cmr.fd)
(/opt/texlive/2007/texmf-dist/tex/latex/psnfss/t1ptm.fd)
No file tmp.out.
No file tmp.out.
INFO: Using normal, i.e. nonfrench-spacing in document
(/opt/texlive/2007/texmf-dist/tex/latex/psnfss/t1phv.fd) [1{/opt/texlive/2007/t
exmf-var/fonts/map/pdftex/updmap/pdftex.map}]
Overfull \vbox (10.0pt too high) has occurred while \output is active [2]
Overfull \vbox (10.0pt too high) has occurred while \output is active [3]
(/opt/texlive/2007/texmf-dist/tex/latex/amsfonts/umsa.fd)
(/opt/texlive/2007/texmf-dist/tex/latex/amsfonts/umsb.fd)
(/opt/texlive/2007/texmf-dist/tex/latex/wasysym/uwasy.fd)
(/opt/texlive/2007/texmf-dist/tex/latex/stmaryrd/Ustmry.fd) [4]

! LaTeX Error: Something's wrong--perhaps a missing \item.

See the LaTeX manual or LaTeX Companion for explanation.
Type  H <return>  for immediate help.
 ...

l.303 ..." hyphenation-remain-character-count="2">
                                                  Chapter 1. Test chapter<...

?
! Emergency stop.
 ...

l.303 ..." hyphenation-remain-character-count="2">
                                                  Chapter 1. Test chapter<...

!  ==> Fatal error occurred, no output PDF file produced!
Transcript written on tmp.log.

Expected results:
creation of a valid pdf file

Additional info:
Comment 1 milady 2007-11-13 11:14:28 EST
Created attachment 257001 [details]
simple xml file
Comment 2 Ondrej Vasik 2007-11-13 11:43:22 EST
Can't reproduce with versions you mentioned:
passivetex-1.25-5.1.1
xmltex-20020625-8
xmlto-0.0.18-17
docbook-dtds-1.0-33.fc8

Please try to run with -v parameter(my output).

Format script: /usr/share/xmlto/format/docbook/pdf
Convert to XSL-FO
Real stylesheet: http://docbook.sourceforge.net/release/xsl/current/fo/docbook.xsl
xmllint >/dev/null --xinclude --postvalid /home/Reset/simple.xml
Stylesheet: /tmp/xmlto-xsl.whqbAn
xsltproc --nonet --xinclude \
 -o /tmp/xmlto.3NymIE/simple.proc \
 /tmp/xmlto-xsl.whqbAn \
 /home/Reset/simple.xml
Making portrait pages on A4 paper (210mmx297mm)
Post-process XSL-FO to PDF

on my machine without texlive(FC-6), so adding texlive(tetex) maintainer to cc.
Comment 3 milady 2007-11-13 12:59:56 EST
Please find my new output using the following packages:
tetex-dvips-3.0-41.fc8
tetex-latex-3.0-41.fc8
tetex-3.0-41.fc8
tetex-fonts-3.0-41.fc8
docbook-style-xsl-1.73.2-2.fc8
docbook-dtds-1.0-32.fc8
docbook-simple-1.1-1.02.fc8
docbook-slides-3.4.0-1.02.fc8
passivetex-1.25-5.1.1
xmltex-20020625-8
xmlto-0.0.18-17

Here goes the output:
$ xmlto -v pdf simple.xml
Format script: /usr/share/xmlto/format/docbook/pdf
Convert to XSL-FO
Real stylesheet: http://docbook.sourceforge.net/release/xsl/current/fo/docbook.xsl
xmllint >/dev/null --xinclude --postvalid /home/andreea/Desktop/simple.xml
Stylesheet: /tmp/xmlto-xsl.j15819
xsltproc --nonet --xinclude \
 -o /tmp/xmlto.x15823/simple.proc \
 /tmp/xmlto-xsl.j15819 \
 /home/andreea/Desktop/simple.xml
Making portrait pages on USletter paper (8.5inx11in)
Post-process XSL-FO to PDF
This is pdfeTeX, Version 3.141592-1.21a-2.2 (Web2C 7.5.4)
entering extended mode
(./tmp.fo
LaTeX2e <2003/12/01>
Babel <v3.8d> and hyphenation patterns for american, french, german, ngerman, b
ahasa, basque, bulgarian, catalan, croatian, czech, danish, dutch, esperanto, e
stonian, finnish, greek, icelandic, irish, italian, latin, magyar, norsk, polis
h, portuges, romanian, russian, serbian, slovak, slovene, spanish, swedish, tur
kish, ukrainian, nohyphenation, loaded.
xmltex version: 2002/06/25 v1.9 (Exp):
(/usr/share/texmf/tex/xmltex/xmltex.cfg)
No File: tmp.cfg (/usr/share/texmf/tex/xmltex/passivetex/fotex.xmt)
(/usr/share/texmf/tex/latex/base/article.cls
Document Class: article 2004/02/16 v1.4f Standard LaTeX document class
(/usr/share/texmf/tex/latex/base/size10.clo))
(/usr/share/texmf/tex/xmltex/passivetex/fotex.sty
)
No file tmp.aux.
(/usr/share/texmf/tex/latex/cyrillic/t2acmr.fd)
(/usr/share/texmf/tex/latex/base/ts1cmr.fd)
(/usr/share/texmf/tex/latex/psnfss/t1ptm.fd)
No file tmp.out.
No file tmp.out.
INFO: Using normal, i.e. nonfrench-spacing in document
(/usr/share/texmf/tex/latex/psnfss/t1phv.fd) [1{/usr/share/texmf-var/fonts/map/
pdftex/updmap/pdftex.map}]
Overfull \vbox (10.0pt too high) has occurred while \output is active [2]
Overfull \vbox (10.0pt too high) has occurred while \output is active [3]
(/usr/share/texmf/tex/latex/amsfonts/umsa.fd)
(/usr/share/texmf/tex/latex/amsfonts/umsb.fd)
(/usr/share/texmf/tex/latex/wasysym/uwasy.fd)
(/usr/share/texmf/tex/latex/stmaryrd/ustmry.fd) [4]

! LaTeX Error: Something's wrong--perhaps a missing \item.

See the LaTeX manual or LaTeX Companion for explanation.
Type  H <return>  for immediate help.
 ...

l.303 ..." hyphenation-remain-character-count="2">
                                                  Chapter 1. Test chapter<...

?
! Emergency stop.
 ...

l.303 ..." hyphenation-remain-character-count="2">
                                                  Chapter 1. Test chapter<...

!  ==> Fatal error occurred, the output PDF file is not finished!
Transcript written on tmp.log.
Comment 4 milady 2007-11-13 13:03:29 EST
Just curious: how do you get the page format to be A4? (I'm assuming it does not
take the format from the regional settings, because I have that set to A4...)
Comment 5 milady 2007-11-13 13:12:09 EST
I just figured out the paper thing (dirty way, I changed it directly in my
docbook/xsl-stylesheets/fo/param.xsl and I told xmlto to use the local stylesheet).

It's worked perfectly with A4 paper!

So I guess the bug is only present when using USLetter paper.
Comment 6 Ondrej Vasik 2007-11-13 15:31:31 EST
I got correct result even for USletter - I think it is taking defaults from
locales, I had cs_CZ.UTF-8 - and it took A4, with en_US.UTF-8 I got good result
for USletter(as default one). Will try tommorrow with the packages you mentioned. 
Comment 7 Jindrich Novy 2007-11-14 07:02:23 EST
It seems like you don't have a pristine tetex installation but also texlive
installed.

I see many of lines like this:

/opt/texlive/2007/texmf-dist/tex/latex/tipa/t3ptm.fd

in your bugreport.

Could you please remove texlive and try it again?
Comment 8 milady 2007-11-14 09:02:16 EST
Done. The output of xmlto using tetex is posted in Comment #3.
Comment 9 Ondrej Vasik 2007-11-19 03:42:56 EST
Tried with F8 packages - and is working without troubles. Are you able to
reproduce the problem on other computer with clean F8 installation? I mean with
no possible conflicts caused by texlive and tetex used at same time. On which
locales you are working? Is there something specific on your system (except
tetex and texlive on one machine) ?
Comment 10 milady 2007-11-19 05:04:41 EST
Locale is French. I don't think there were conflicts between tetex and texlive,
because I completely erased tetex before installing texlive. And then I
completely erased texlive, when I reinstalled tetex to post its output here.

Anyway, I'll try it on my personal machine this evening (I have a brand new and
clean F8 installed on it).
Comment 11 Ondrej Vasik 2007-11-28 11:12:14 EST
Any news about that try on clean F8? 
Comment 12 milady 2007-11-28 16:01:11 EST
It's working on the clean F8 with both letter and A4 paper... I guess the
problem is with more complicated files. This is how I discovered the bug in the
first place: since my real file wasn't working I thought I should try with a
simple dummy file and that didn't work either. 

But now this is working and my real file still doesn't compile. According to
OSDIR (exactly the same problem as mine:
http://osdir.com/ml/internationalization.french/2005-10/msg00034.html), it's
hopeless, since apparently passivetex cannot handle more complex docbook files.
Is that right? Is there any chance this may be fixed in some future version?

Thanks.
Comment 13 Ondrej Vasik 2007-11-28 18:29:55 EST
Sorry - I don't understand french, so got nothing from that OSDIR message. 
About your question - last version of passivetex is 3 years old. There are many
things unfinished, many things not handled correctly. 

In some cases could help usage of sgml toolchain instead of xml toolchain
(jw -f docbook -b pdf <xmlfile.xml>)

In near future there will be hopefully xmlto version which will allow to use of
fop instead of passivetex. I'm now upstream of xmlto(got it from Tim Waugh), so
I hope it will be soon.

That behaviour was probably caused by something strange on system. Closing that
one as WORKSFORME. Feel free to reopen it if you find something new/specific
what could help me to catch possible problem.

Note You need to log in before you can comment on or make changes to this bug.