This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 38052 - Installer exits after error when running lilo.
Installer exits after error when running lilo.
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-27 08:32 EDT by Gregor Anich
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-27 14:34:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error message anaconda gives (916 bytes, text/plain)
2001-04-27 08:33 EDT, Gregor Anich
no flags Details

  None (edit)
Description Gregor Anich 2001-04-27 08:32:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)


Installer exits when trying to install lilo

Reproducible: Always
Steps to Reproduce:
1. Putting redhat seawolf disc1 in DVD-ROM
2. Booting from redhat seawolf disc1
3. Configuring installation options
4. Starting installaion
5. After installation (I guess lilo is tried to be installed) i get this 
error message from descreption

note:
i've tried 3times - same error every time
	

Actual Results:
  anacdump.txt:
Traceback (innermost last):
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/iw/progress_gui.py", line 
19, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 2081, in 
doInstall
    self.hdList, self.upgrade, langlist)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/lilo.py", line 462, in 
install
    catchfd = 2, closefd = 1)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/iutil.py", line 108, in 
execWithCapture
    raise RuntimeError, command + " can not be run"
RuntimeError: /mnt/sysimage/sbin/lilo can not be run

Local variables in innermost frame:
argv: ['lilo', '-r', '/mnt/sysimage']
root: /
stdin: 0
closefd: 1
command: /mnt/sysimage/sbin/lilo
searchPath: 0
catchfd: 2

ToDo object:
(itodo
ToDo
p1
(dp2
S'resState'
p3
S'1600x1200'
p4
sS'progressWindow'
p5
(igui
ProgressWindow
(dp6
S'total'
p7
I445
sS'window'
p8
(igtk
GtkWindow
(dp9
S'_o'
p10

<failed>

---------
during shut down of installer i could see another error message:
/mnt/sysimage umount() failed
!

Expected Results:  lilo installs and i can start using redhat 7.1 :)

here some info 'bout my hard disks:
hda:
  hda1: fat32 (~1GB)
  hda2: swap  (133mb)
  hda3: ext2  (~8GB)    /
  hda4: fat32 (~20GB)
hdb:
  hdb1: ext2  (23mb)    /boot
  hdb2: fat32 (~20GB)
hdc:
  hdc1: fat32 (~2GB)

pioneer dvd-rom a05sz (firmware rpc1-patched :)
Comment 1 Gregor Anich 2001-04-27 08:33:37 EDT
Created attachment 16645 [details]
error message anaconda gives
Comment 2 Brent Fox 2001-04-27 09:08:58 EDT
Did you buy the product or did you download it?  If you downloaded it, I think
either something got corrupted during the download or the cd is bad somehow.
When the installer crashes, can you press <Ctrl><Alt><F3> and <Ctrl><Alt><F4>
and see if you see any error messages (like 'cdrom seek error)?
Comment 3 Gregor Anich 2001-04-27 13:19:53 EDT
i could fix it somehow! i'm not going to install again and check for error 
messages :)

i downloaded BUT i did md5sum check and everything was o.k.!

i still got some problems with lilo (can't boot windows) and it took me long 
till i could install lilo (had to install lilo from cd, then install kernel 
from cd, ... :)
Comment 4 Brent Fox 2001-04-27 14:34:38 EDT
I'm happy that you seem to have found a workaround.  Unfortunately, if I can't
reproduce the problem, then I don't have much hope of fixing it.
Comment 5 Gregor Anich 2001-04-28 04:45:23 EDT
i'm happy you can't reproduce! could the problem be my HD? when i run fsck 
on /boot i get lots of errors... and when i try to install lilo there is a 
warning for windows (/dev/hda1) and if i try to boot windows from lilo i'm 
getting error 0x31 or 0x30 (can't remember - sorry)
Comment 6 Brent Fox 2001-04-30 12:18:14 EDT
Yeah, sounds like something's wrong with the hard drive.  I can't be sure, but
it sounds that way.  The drive may not be physically damaged, though...it could
just have a corrupted partition table or something like that.
Comment 7 Gregor Anich 2001-05-02 06:42:53 EDT
yeah.... i've tried fdisk /dev/hdb and i got an error telling me something with partition 
table.... but after i unmounted /boot i had all the kernel files still in /boot so /boot is a 
directory on /hda3 which contains all boot-files instead of everything being on 
/dev/hdb1 (which should be mounted on /boot).... i don't think redHat could have made 
such a mistake that it is not mounting those partitions which i choose a mountpoint for 
in installer.... i know the following should get an extra bug id but some others may have 
posted already:
when i make a new user for myself in the installer and the click "OK" i don't get any 
message and the user isn't added in the table below.... i thought "maybe the user was 
created but not entered in the table" but after i booted my system just user root was 
there!

Note You need to log in before you can comment on or make changes to this bug.