Bug 380561 - Add ability to set cluster_id in conga
Add ability to set cluster_id in conga
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: conga (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Jim Parsons
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-13 12:40 EST by Ryan O'Hara
Modified: 2009-04-16 18:55 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-20 17:53:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan O'Hara 2007-11-13 12:40:02 EST
It might be nice to let users specify the cluster ID in Conga. This parameter is
an attribute of the cman element in cluster.conf. Example:

<cman cluster_id="1234"/>

This attribute is completely optional. If it is not explicitly defined, cman
will generate one based on the cluster name. However, when using scsi
reservations as a fence method, it is *recommended* that you explicity define a
unique cluster ID. The reason is that this value is used to generate unique scsi
reservation keys. By combining cluster ID and node ID we can generate a unique
reservation key for each node.

cluster_id (in C) is a 16-bit value, if that matters. So its max value would be
65535 (0xFFFF hex), in case Conga does any range checks.
Comment 1 Jim Parsons 2007-11-13 12:52:48 EST
What happens if the cluster is already running, and a user happens upon this
form field, and decides they want to put their phone number in the cluster ID
field for fun...will suddenly changing the cluster ID param in the conf file
break anything?
Comment 2 Ryan O'Hara 2007-11-13 14:21:15 EST
Yes. Just like changing your node IDs would break your scsi reservation keys.
Changing either your cluster ID or node IDs while you have existing
reservations/registrations is a bad idea.
Comment 5 RHEL Product and Program Management 2008-05-20 17:53:04 EDT
Product Management has reviewed and declined this request.  You may appeal this
decision by reopening this request. 

Note You need to log in before you can comment on or make changes to this bug.