Bug 380861 - Superkey (windows key) doesn't work
Superkey (windows key) doesn't work
Status: CLOSED DUPLICATE of bug 239409
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-keyboard (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Peter Hutterer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-13 15:08 EST by markm
Modified: 2008-08-22 01:51 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-22 01:51:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 7008 None None None Never

  None (edit)
Description markm 2007-11-13 15:08:15 EST
Description of problem:

One day I start my computer and superkey works fine, another day it doesn't.
very annoying as lot's of compiz-fusion effects require superkey. 

Version-Release number of selected component (if applicable):

I am not sure which component is responsible for that - I am using updated
Fedora 8 (the same problem was on Fedora 7 too)

How reproducible:

randomly - 50/50

Steps to Reproduce:
1. log in
2. press superkey
3. nothing happens
  
Actual results:

nothing happens

Expected results:

should see right click menu

Additional info:
Comment 1 Matěj Cepl 2007-11-14 09:20:28 EST
Could we get output of xev when pressing the superkey?
Comment 2 markm 2007-11-14 16:00:37 EST
I am getting that:

KeyPress event, serial 31, synthetic NO, window 0x5800001,
    root 0x1a6, subw 0x0, time 1072738366, (1137,607), root:(1142,653),
    state 0x0, keycode 115 (keysym 0xffeb, Super_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyRelease event, serial 31, synthetic NO, window 0x5800001,
    root 0x1a6, subw 0x0, time 1072738542, (1137,607), root:(1142,653),
    state 0x0, keycode 115 (keysym 0xffeb, Super_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

but while I am pressing for example super+E - it should run expo plugin from
compiz-fusion, but it does not.

I have found quick solution for that - I need to open Keyboard preferences, then
on the tab 'Layout Options' I need to select 'Super is mapped to the Win-keys'
for 'Alt/Win key behaviour' and super key works. even if I select back
'Default', it works fine. till next logon, when I've got 50% chance, it won't
work :)
Comment 3 markm 2007-12-11 20:44:49 EST
after latest update super key stopped working completely on two different
machines, a "quick solution" doesn't help this time :( but xev output is still
the same (it showed that Super_L was pressed).
Comment 4 markm 2008-01-15 09:34:04 EST
starting fusion-icon surprisingly solves the problem... 
Comment 5 Ira Malinich 2008-02-13 00:11:36 EST
This may be related to Bug #189518 which has to do with the order either of the
Shift and Alt keys are pressed.  When the Windows key is misbehaving on any of
my machines, the Shift and Alt behaviour is broken as well.  I found the
keyboard preferences fix temporarily works for both problems.

There is a bug open at freedesktop.org about both of these issues, but neither
seem to be getting anywhere.  The Windows key bug is #7008.
Comment 6 Matěj Cepl 2008-06-06 04:48:27 EDT
Another candidate for deduplication is bug 239409
Comment 7 Doncho N. Gunchev 2008-08-08 17:27:42 EDT
(In reply to comment #6)
> Another candidate for deduplication is bug 239409

How can bug 239409 (Reported: 2007-05-08 05:25 EDT) be duplicate of bug 380861 (Reported: 2007-11-13 15:08 EDT)?
Comment 8 Stefan Becker 2008-08-19 03:12:49 EDT
(In reply to comment #7)
> (In reply to comment #6)
> > Another candidate for deduplication is bug 239409
> 
> How can bug 239409 (Reported: 2007-05-08 05:25 EDT) be duplicate of bug 380861
> (Reported: 2007-11-13 15:08 EDT)?

Because it is describing exactly the same problem: Super_L (Left Windows Key) sometimes works as modifier, sometimes not. Could the author please mark this as duplicate of bug 239409?

Verified that problem still exists on Fedora 9 with

  xorg-x11-server-Xorg-1.4.99.905-2.20080702.fc9.i386
Comment 9 Peter Hutterer 2008-08-22 01:51:53 EDT

*** This bug has been marked as a duplicate of bug 239409 ***

Note You need to log in before you can comment on or make changes to this bug.