Bug 380901 - SystemsAffected tab in erratum details doesn't list all affected systems
Summary: SystemsAffected tab in erratum details doesn't list all affected systems
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site   
(Show other bugs)
Version: rhn500
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Grant Gainey
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 345571
TreeView+ depends on / blocked
 
Reported: 2007-11-13 20:22 UTC by daryl herzmann
Modified: 2007-12-10 16:15 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-10 16:14:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description daryl herzmann 2007-11-13 20:22:16 UTC
Sorry if this is a dup.  I have some suggestions for the SystemsAffected tab for
the errata page, like so:

https://rhn.redhat.com/rhn/errata/details/SystemsAffected.do?eid=6085

The text states "Below is a list of systems affected by this erratum."  That is
sort of misleading, since systems that have already applied this errata are not
listed.  May I suggest either:

1) Add the systems that have applied the errata to the page and list their  
   completed status.

2) Change the text to say: "Below is a list of systems that have yet to process
   this erratum."  or something like that :)

If you pick #2, it would be nice to create some other sort of indication of
which systems did infact apply the errata.  Maybe I am missing something in the UI.

thanks!

Comment 1 Máirín Duffy 2007-12-10 16:14:59 UTC
see bug 237590. 

the real bug here is that the affected systems tab of an erratum details page
has not listed all affected systems. this was apparently a taskomatic issue that
was fixed in bug 237590.

if the affected systems tab continues to be incorrect, please reopen this bug.

---

1 & 2 above do not make sense, because there are systems unaffected by an
erratum because they have newer package version that may not have ever
explicitly applied that erratum (they may have had a upgrade action scheduled
instead.) errata are additive throughout package versions, so version 2 of a
package will have all the errata fixes in it that occurred between versions 1 and 2.

Comment 2 Máirín Duffy 2007-12-10 16:15:41 UTC
bug 237590 was fixed in rhn 501, btw.


Note You need to log in before you can comment on or make changes to this bug.