Bug 3811 - /etc/profile.d/kde.csh
/etc/profile.d/kde.csh
Status: CLOSED DUPLICATE of bug 3686
Product: Red Hat Linux
Classification: Retired
Component: kdesupport (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-29 13:35 EDT by klmitch
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-30 18:53:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description klmitch 1999-06-29 13:35:11 EDT
1) var=value syntax doesn't work in csh
2) If the bad syntax is fixed, "if" bails out with
   "Expression Syntax."

Both of these problems mean my tcsh dot files don't get
run.

The relevant lines are flagged below with '*':
------------------------------------------------------------
# KDE initialization script (csh)
if ( $?KDEDIR ) then
         if ( $KDEDIR == "/usr" ) then
         exit
         endif
endif
setenv KDEDIR /usr
kdepath="${KDEDIR}/bin" *
if ( echo ${PATH} | grep -q ${kdepath} ) then *
  exit
endif

setenv PATH "${kdepath}:${PATH}"
------------------------------------------------------------
Suggested fixes:

First line should read, 'set kdepath = "${KDEDIR}/bin"'
I'm not sure about the appropriate if syntax; maybe some
appropriately placed backtics would fix it.
Comment 1 Jeff Johnson 1999-06-30 18:53:59 EDT
*** This bug has been marked as a duplicate of 3686 ***

Note You need to log in before you can comment on or make changes to this bug.