Bug 38111 - RAID funkiness (md: bug in file md.c...)
Summary: RAID funkiness (md: bug in file md.c...)
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 1.0
Hardware: alpha Linux
low
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-27 21:37 UTC by Elliot Lee
Modified: 2005-10-31 22:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-13 12:29:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel-smp-2.4.3-2.14.4 boot log on ostrich-deluxe.labs.redhat.com (25.33 KB, text/plain)
2001-04-27 21:41 UTC, Elliot Lee
no flags Details
ostrich-deluxe.labs.redhat.com:/etc/raidtab (534 bytes, text/plain)
2001-04-27 21:43 UTC, Elliot Lee
no flags Details
The utility I used to solve the problem, for historical interest only (3.84 KB, application/x-tar)
2002-06-13 12:29 UTC, Elliot Lee
no flags Details

Description Elliot Lee 2001-04-27 21:37:56 UTC
Things get "weird" when trying to boot the wolverine-alpha2 kernel on this
UW533au2.

A relevant detail may be that the 2.2 kernel sometimes has to spin /dev/sdg
up during boot. Otherwise, everything seems to function normally under
2.2.17ish.

I will attach the 2.4 boot log and the raidtab file. Please let me know
what other information might be useful.

Comment 1 Elliot Lee 2001-04-27 21:41:55 UTC
Created attachment 16689 [details]
kernel-smp-2.4.3-2.14.4 boot log on ostrich-deluxe.labs.redhat.com

Comment 2 Elliot Lee 2001-04-27 21:43:11 UTC
Created attachment 16690 [details]
ostrich-deluxe.labs.redhat.com:/etc/raidtab

Comment 3 Elliot Lee 2001-06-29 18:12:51 UTC
Going to add Bryce to the Cc: list just because he claimed it had been fixed,
and it still hasn't. :)

Comment 4 Phil Copeland 2001-06-29 18:37:08 UTC
<Grumble> I can't fix what I can't replicate
As and when I can, I'll retackle this problem

Thanks

Phil
=--=

Comment 5 Elliot Lee 2001-07-02 22:11:54 UTC
Linux/Alpha 2.2.x: sizeof(mdp_super_t) == 4104, offsetof(mdp_super_t,
gstate_reserved) == 168

Linux/Alpha 2.4.x: sizeof(mdp_super_t) == 4096, offsetof(mdp_super_t,
gstate_reserved) == 164.

It looks like someone seriously broke on-disk backwards compat during the
attempt to whittle mdp_super_t down to a dividable-by-1024 size.

Ingo added to Cc's because he probably knows what is going on.

Comment 6 Elliot Lee 2001-07-03 00:01:10 UTC
Changing priority to 'low' because I hacked a util to do the conversion.

Comment 7 alvin 2002-04-23 16:18:56 UTC
This ends up being an alignment bug.
The event counter was a 64 bit item and as such was 64bit aligned so there was a
32bit pad before the counter in the 2.2 version of the structure.
the 2.4 version of the structure has 2 32 bit items as the event counter. These
are now 32bit aligned and the padding has gone away.

I have a small patch to check for this condition and repare the raidtable but I
am not sure if it is truly ok to do this.

Comment 8 Elliot Lee 2002-04-23 16:29:59 UTC
I can confirm your description because I found the same thing out when creating
the conversion utility. The only question is whether the kernel dudes will ever
do something about it :)

Comment 9 Phil Copeland 2002-04-23 18:32:19 UTC
/me twiddles thumbs,...

Files, patchs?

Phil
=--=



Comment 10 Elliot Lee 2002-06-13 12:29:43 UTC
Created attachment 60825 [details]
The utility I used to solve the problem, for historical interest only

Comment 11 Elliot Lee 2002-06-13 12:30:55 UTC
If you're not gonna fix it, say so...


Note You need to log in before you can comment on or make changes to this bug.