Bug 381201 - zipl fails when section is specified and target is not repeated for all sections
zipl fails when section is specified and target is not repeated for all sections
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: s390utils (Show other bugs)
5.1
s390x Linux
high Severity medium
: ---
: ---
Assigned To: Dan Horák
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-13 17:06 EST by Brad Hinson
Modified: 2011-01-24 17:15 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.5.3-17.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:49:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brad Hinson 2007-11-13 17:06:54 EST
Description of problem:
With the default zipl.conf and one or more sections defined, 'zipl linux' with
any combination of options fails with 'missing keyword target' error.

Version-Release number of selected component (if applicable):
s390utils-1.5.3-10.el5.14

How reproducible:
100%

Steps to Reproduce:

# cat /etc/zipl.conf 
[defaultboot]
default=2.6.18-54.el5.b
target=/boot/
[2.6.18-54.el5.b]
        image=/boot/vmlinuz-2.6.18-54.el5.bz325451.rm7
        ramdisk=/boot/initrd-2.6.18-54.el5.bz325451.rm7.img
        parameters="root=/dev/VolGroup00/LogVol00"
[linux]
        image=/boot/vmlinuz-2.6.18-52.el5
        ramdisk=/boot/initrd-2.6.18-52.el5.img
        parameters="root=/dev/VolGroup00/LogVol00"

# zipl linux
Using config file '/etc/zipl.conf'
Error: Config file '/etc/zipl.conf': Line 4: missing keyword 'target' in section
'2.6.18-54.el5.b'


Additional info:
1.) The only way to get this to work successfully is to repeat the
'target=/boot/' option for each section, including the [defaultboot] section at
the top.

2.) This is similar to running zipl with '-x'.  The '-x' option, as documented
in the zipl(8) man page, says that specifying a section on the commandline
disables the automenu.  However, running 'zipl -x --target=/boot/ -i=... -r=...'
works.  When running 'zipl linux --target=/boot/ -i=... -r=...', zipl returns
the error:

Error: Option 'image' cannot be used when specifying a configuration section
Comment 2 Phil Knirsch 2007-11-27 10:58:20 EST
I think i have a suspicion where the problem might come from, will investigate
in the next few days.

Read ya, Phil
Comment 3 RHEL Product and Program Management 2007-12-03 15:47:41 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release.  This request will
be reviewed for a future Red Hat Enterprise Linux release.
Comment 4 Issue Tracker 2008-04-01 09:36:29 EDT
----- Additional Comments From suzukikp@in.ibm.com (prefers email at
suzuki@in.ibm.com)  2008-04-01 03:31 EDT -------
--- Additional info from 43310 ---

Looks like the "target=" option is mandatory for all the sections in
the
zipl.conf file.

This worked fine for your original /etc/zipl.conf file, since there was
only one
section and thus it was fine. But when you added another section
("[dump_dasd]")
it requires that you have to add "target=" for each section.

Thanks

Suzuki

----------------------------- 


This event sent from IssueTracker by jkachuck 
 issue 129816
Comment 5 RHEL Product and Program Management 2008-06-04 18:47:51 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 6 Dan Horák 2008-07-04 08:05:26 EDT
The upstream documentation
(http://download.boulder.ibm.com/ibmdl/pub/software/dw/linux390/docu/l26cdd04.pdf,
page 396, available at
http://www-128.ibm.com/developerworks/linux/linux390/october2005_documentation.html)
says:

The default section consists of the section identifier [defaultboot] followed by a
single option line. The option line specifies one of these mutually exclusive
options:
...

So the comment #4 is right, see page 387 for details.

The following config should work
[defaultboot]
default=2.6.18-54.el5.b
[2.6.18-54.el5.b]
        image=/boot/vmlinuz-2.6.18-54.el5.bz325451.rm7
        ramdisk=/boot/initrd-2.6.18-54.el5.bz325451.rm7.img
        parameters="root=/dev/VolGroup00/LogVol00"
        target=/boot
[linux]
        image=/boot/vmlinuz-2.6.18-52.el5
        ramdisk=/boot/initrd-2.6.18-52.el5.img
        parameters="root=/dev/VolGroup00/LogVol00"
        target=/boot

Please, can you check it?
Comment 7 Brad Hinson 2008-07-11 10:46:08 EDT
With the config in comment 6, you get the error:

# zipl linux --dry-run
Using config file '/etc/zipl.conf'
Error: Config file '/etc/zipl.conf': Line 1: missing keyword 'target' in section
'defaultboot'

Adding target= back to [defaultboot] (so target= is in 3 places) works.  Not
sure if this is expected behavior.  The documentation is a little unclear on
this.  On p. 396, it makes it appear that the [defaultboot] only requires a
default= or defaultmenu= parameter.
Comment 8 Dan Horák 2008-07-14 08:20:32 EDT
Hmm, it is our "automenu" patch that modifies the default upstream behavior. But
as I see you are using a package that is now out-of-date, RHEL 5.2 has an
updated version (s390utils-1.5.3-17.el5) and with this version an equivalent
config works on my machine. Can you recheck your config with this updated
version of s390utils?
Comment 9 Issue Tracker 2008-07-14 11:03:04 EDT
------- Comment From mgrf@de.ibm.com 2008-07-14 10:45 EDT-------
(In reply to comment #51)
> ------- Comment #2171043 from bugzilla at 2008/07/14 07:20:33 EDT
-------
> These changes made by dhorak@redhat.com.
> Bugzilla comment added:
> Hmm, it is our "automenu" patch that modifies the default upstream
behavior. But
> as I see you are using a package that is now out-of-date, RHEL 5.2 has
an
> updated version (s390utils-1.5.3-17.el5) and with this version an
equivalent
> config works on my machine. Can you recheck your config with this
updated
> version of s390utils?

Hello Red Hat:
Can you please post your config used and results for comparison please?

Resolution set to: 'Unknown'

This event sent from IssueTracker by jkachuck 
 issue 129816
Comment 10 Brad Hinson 2008-07-14 12:25:43 EDT
I ran the tests in comment 7 on the 5.2 s390utils:

# rpm -q s390utils
s390utils-1.5.3-17.el5
Comment 11 Dan Horák 2008-07-14 12:34:37 EDT
Don't you have an older zipl somewhere?

[root@s390x ~]# rpm -q s390utils
s390utils-1.5.3-17.el5
[root@s390x ~]# which zipl
/sbin/zipl
[root@s390x ~]# 

my config (zipl-test.conf):
-----
[defaultboot]                                                                  
                    
default=2.6.18-92.el5                                                          
                    
target=/boot/                                                                  
                    
[2.6.18-92.el5]                                                                
                    
        image=/boot/vmlinuz-2.6.18-92.el5                                      
                    
        ramdisk=/boot/initrd-2.6.18-92.el5.img                                 
                    
        parameters="root=/dev/VolGroup00/LogVol00"                             
                    
[linux]                                                                        
                    
        image=/boot/vmlinuz-2.6.18-92.el5                                      
                    
        ramdisk=/boot/initrd-2.6.18-92.el5.img                                 
                    
        parameters="root=/dev/VolGroup00/LogVol00"                             
                    
-----

[root@s390x ~]# zipl -c zipl-test.conf --dry-run
Using config file 'zipl-test.conf' (from command line)
Starting dry-run, target device contents will NOT be modified
Building bootmap in '/boot/'
Building menu 'rh-automatic-menu'
Adding #1: IPL section '2.6.18-92.el5' (default)
Adding #2: IPL section 'linux'
Preparing boot device: dasda (0120).
Done.
Comment 12 Dan Horák 2008-07-14 12:45:38 EDT
Oh, sorry, I see it now, I forgot to add the "linux" option to my command line.
Comment 20 errata-xmlrpc 2009-01-20 16:49:24 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0188.html

Note You need to log in before you can comment on or make changes to this bug.