Bug 38134 - make clean;make dep;make;make modules fails on new install
make clean;make dep;make;make modules fails on new install
Status: CLOSED DUPLICATE of bug 38133
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-27 19:09 EDT by Marisa Giancarla
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-27 19:09:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marisa Giancarla 2001-04-27 19:09:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)


I thought maybe I had removed a needed component so I did a complete
reinstall and tried it and got the same thing. Wiith or wthout making any
kernel config changes the kernel refuses to build the modules, failing on
the first module the config falls for. Changing the kernel config to add or
remove drivers as modules will cause the system to fail on whatever the new
first module to be built is. Help!

Reproducible: Always
Steps to Reproduce:
1.Do an install based on the downloadable RHL 7.1 CD ISO images, installing
the normal set of packages that would be required to rebuild the kernel
2.cd into the kernal source tree
3.run "make menuconfig" and when it comes up just exit without making any
changes
4.Now run "make dep;make". This should run and complete normally with a
fresh vmlinux
5.Now do "make modules"
	

Actual Results:  It should fail on the first module it has to build, which
for me with the default config is "net/dummy.o". If you edit the config and
add some more drivers to be built as modules then do the "make dep;make"
part again it will fail on whatever the new first module is with the same
errors in the same file:
make[2]: Entering directory `/usr/src/linux-2.4.2/drivers/net'
gcc -D__KERNEL__ -I/usr/src/linux-2.4/include -Wall -Wstrict-prototypes -O2
-fomit-frame-pointer -fno-strict-aliasing -fno-common -Wno-unused -pipe
-mpreferred-stack-boundary=2 -march=i686 -DMODULE -DMODVERSIONS -include
/usr/src/linux-2.4/include/linux/modversions.h   -c -o dummy.o dummy.c
In file included from /usr/src/linux-2.4/include/linux/spinlock.h:35,
                 from /usr/src/linux-2.4/include/linux/module.h:11,
                 from dummy.c:34:
/usr/src/linux-2.4/include/asm/spinlock.h:8: nondigits in number and not
hexadecimal
/usr/src/linux-2.4/include/asm/spinlock.h:8: nondigits in number and not
hexadecimal
/usr/src/linux-2.4/include/asm/spinlock.h:8: parse error before `1b7d4074'
/usr/src/linux-2.4/include/asm/spinlock.h:9: `printk_R_ver_str' declared as
function returning a function
/usr/src/linux-2.4/include/asm/spinlock.h:9: warning: function declaration
isn't a prototype


Expected Results:  Should have built up the dynamicly loadable modules
Comment 1 Arjan van de Ven 2001-04-28 04:03:34 EDT
You MUST load the config file of the kernel you are running first (see the
config directory) and if you change a lot, you also must run make mrproper.

*** This bug has been marked as a duplicate of 38133 ***

Note You need to log in before you can comment on or make changes to this bug.