Bug 381351 - Some emails do not display in Evo-exchange inbox and other folders
Some emails do not display in Evo-exchange inbox and other folders
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution-exchange (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-13 19:34 EST by Stewart Hardie
Modified: 2008-01-29 08:27 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-29 08:27:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 478151 None None None Never

  None (edit)
Description Stewart Hardie 2007-11-13 19:34:36 EST
Description of problem:
I have set up an Exchange set of folders in Evo 2.12.1. I am currently looking
at the Inbox and see no emails. However, using Outlook web access in Firefox, I
can plainly see a new email sitting there in the Inbox. This is one simple and
blatant case of some emails not displaying in Evo exchange folders. There is
another similar case of emails not showing up in Evo in other folders too.

I delete .evolution/exchange and .evolution/mail/exchange folders, and restart
Evo. I briefly see the new inbox email for a fraction of a second, and then it
vanishes, not to be seen again. No chance to click it and read it.

A couple of days ago, there were over a dozen new emails in the Inbox, which
refused to show up in Evo-exchange inbox. I only found out about them, when
checking from another computer via IMAP.

A bunch of other emails in the inbox I had already read also vanished, and I
thought they had been lost, until I checked via firefox OWA. They were still
there, just no longer displaying in Evo-exchange inbox.

Evo does not seem to crash or lock up in any way when this happens.

I never noticed this behaviour in previous versions of Evo.

This is a serious problem, as new and used emails do not display even when they
appear to be present on the exchange server. This makes Evo fast become unusable
if an Exchange server is being used.

http://www.mail-archive.com/evolution-hackers@gnome.org/msg01962.html
This link shows a comment (bug 478151) about not seeing emails, which seems
similar to this problem.

http://bugzilla.gnome.org/show_bug.cgi?id=478151
This describes the problem in some way, although my todays, new emails vanish,
not just ones before july 2007. Also, deleting the .evolution/exchange and
.evolution/mail/exchange folders no longer seems to fix the problem for me.

Version-Release number of selected component (if applicable):
2.12.1

How reproducible:
Random occurence, but happens on a daily basis.

Steps to Reproduce:
1. Set up Evo-exchange folders.
2. Wait for emails to vanish, whether ones already there or new ones that never
show up (until you notice them when checking via Firefox OWA or IMAP)

  
Actual results:
Emails randomly disappear, even new ones (so that you never knew they existed).

Expected results:
All emails in various Evo-exchange folders should reflect what is actually in
the various Exchange server email folers.
Comment 1 Nik Lam 2007-11-28 04:57:29 EST
I'm experiencing these same symptoms on Fedora 8 (i386).

In addition to gnome bug 478151, see also:

http://bugzilla.gnome.org/show_bug.cgi?id=435371
http://bugzilla.gnome.org/show_bug.cgi?id=442098
http://bugzilla.gnome.org/show_bug.cgi?id=497949
Comment 2 Russell Harrison 2008-01-23 08:46:19 EST
I have also seen these problems from time to time.  I have switched over to
setting up an IMAP account I actually read my email in, and the exchange account
I only use to get calendar information because of them.
Comment 3 Matthew Barnes 2008-01-29 08:27:00 EST
Since this has been reported upstream, I'm moving this bug report to

http://bugzilla.gnome.org/show_bug.cgi?id=478151

Note You need to log in before you can comment on or make changes to this bug.