Bug 381431 - Gnome Settings broken by latest fedora 8 updates
Summary: Gnome Settings broken by latest fedora 8 updates
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center
Version: 8
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-14 02:47 UTC by Aditya Kadambi
Modified: 2007-11-30 22:12 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2007-11-15 01:06:17 UTC


Attachments (Terms of Use)
rpm output for gnome_vfs2 (48 bytes, text/plain)
2007-11-14 15:53 UTC, Aditya Kadambi
no flags Details
rpm verbose output for gnome_vfs2 (5.69 KB, text/plain)
2007-11-14 15:54 UTC, Aditya Kadambi
no flags Details
/var/log/messages file (942.54 KB, text/plain)
2007-11-14 15:57 UTC, Aditya Kadambi
no flags Details

Description Aditya Kadambi 2007-11-14 02:47:00 UTC
Description of problem:
gnome-settings daemon won't start. Broken by latest fedora 8 updates.

Version-Release number of selected component (if applicable):

Fedora 8, gnome2


How reproducible:

Everytime. After logging in, gnome-settings daemon does not start. Hence cannot
launch any application from the menu. Also, icons are missing from the
desktop.Launching any application from menu (say Application->System
Tools->Terminal), results in the following message:

Error
Could not start menu item

Error reading file
'file:///usr/share/applications/gnome-terminal.desktop':Unsupported operation.


Steps to Reproduce:
1. Login with latest updates from Fedora
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Aditya Kadambi 2007-11-14 03:56:17 UTC
After rebooting several times and deleting all GNOME configuration files, I get
two error pop up messages (alas, can't take screenshots since everything is
broken and can't be started from menu)

Contents of first pop up message:

"There was an error starting the GNOME Settings Daemon.

Some things, such as themes, sounds, or background settings may not work correctly.

The Settings Daemon restarted too many times.

GNOME will still try to restart the Settings Daemon next time you log in."

Contents of second popup message:

Error

If you reload a panel object, it will automatically be added back to the panel.


F8 system is not usuable in X mode


Comment 2 Ray Strode [halfline] 2007-11-14 07:19:33 UTC
If you log in as your normal user from a text console, does 

cat /usr/share/applications/gnome-terminal.desktop

work?

What's the output of 

rpm -q  gnome-vfs2 && rpm -V gnome-vfs2

?

can you attach /var/log/messages ?

Did this work before and break after getting updates?

Comment 3 Aditya Kadambi 2007-11-14 15:53:58 UTC
Created attachment 258201 [details]
rpm output for gnome_vfs2

Comment 4 Aditya Kadambi 2007-11-14 15:54:58 UTC
Created attachment 258211 [details]
rpm verbose output for gnome_vfs2

Comment 5 Aditya Kadambi 2007-11-14 15:57:44 UTC
Created attachment 258241 [details]
/var/log/messages file

Comment 6 Aditya Kadambi 2007-11-14 16:00:13 UTC
"If you log in as your normal user from a text console, does 

cat /usr/share/applications/gnome-terminal.desktop

work?"

Yes, it does work. I can cat all other application files too.

Yes, everything worked before updates. Now, gnome-desktop doesn't.

Comment 7 Ray Strode [halfline] 2007-11-14 16:15:47 UTC
The md5sum of some of files in the gnome-vfs2 package doesn't match what rpm is
expecting.

can you force reinstall the x86-64 gnome-vfs2 package and see if that addresses
your issue?

Comment 8 Aditya Kadambi 2007-11-15 01:06:17 UTC
I tried removing the package and ended up with a whole bunch of ext3 errors due
to SELinux.

I just went ahead and did a fresh re-install and took the aforementioned
updates. Everything in Gnome works now.

Looks like the initial install didn't go well WRT to GNOME, even though it was a
fresh install.

Thanks for all your help. I am marking this as resolved.


Note You need to log in before you can comment on or make changes to this bug.