Bug 381481 - clucene-config.h missing in clucene-core-devel package
clucene-config.h missing in clucene-core-devel package
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: clucene (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Deji Akingunola
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-13 22:52 EST by Harry Bock
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-13 23:15:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harry Bock 2007-11-13 22:52:56 EST
Description of problem:
The Fedora 8 package for clucene-core-devel does not contain clucene-config.h
(found in /usr/include/CLucene) which is required for building against CLucene.
The Fedora 7 package works fine.

Version-Release number of selected component (if applicable):
clucene-core-devel-0.9.20-2.fc8.x86_64 / i386

How reproducible:
Build any clucene-dependent package from source.
Attempt to build kdesupport from trunk

Steps to Reproduce:
1. Install clucene-core-devel
2. Attempt to build kdesupport from trunk
3.
  
Actual results:
CMake fails to find /usr/include/CLucene/clucene-config.h and cannot proceed

Expected results:
Build proceeds successfully.


Additional info:
Building clucene 0.9.20 from source and copying the generated clucene-config.h
to /usr/include/CLucene rectifies the problem and building kdesupport succeeds.
Comment 1 Deji Akingunola 2007-11-13 23:15:37 EST
clucene-config.h is now under /usr/lib{64}/CLucene, which is where upstream want
it to be. That in fact seems to be its right place as it (potentially) has
arch-specific defines. I think kdesupport needs to be patch to look in the
'right' place for it.

Note You need to log in before you can comment on or make changes to this bug.