Bug 381501 - dmraid needs to activate device-mapper mirror resynchronization error handling
dmraid needs to activate device-mapper mirror resynchronization error handling
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dmraid (Show other bugs)
5.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ian Kent
Corey Marthaler
:
Depends On: 379961
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-13 23:14 EST by Ian Kent
Modified: 2008-12-10 13:41 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-10 13:41:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to add handle_error argument (404 bytes, patch)
2007-11-13 23:14 EST, Ian Kent
no flags Details | Diff

  None (edit)
Description Ian Kent 2007-11-13 23:14:14 EST
+++ This bug was initially created as a clone of Bug #379961 +++

+++ This bug was initially created as a clone of Bug #379951 +++

Description of problem:
dmraid needs to add the 'handle_errors' argument to mapping tables created for
mirror mappings in order to take advantage of the resynchronization error handling.

Version-Release number of selected component (if applicable):


How reproducible:
Always.

Steps to Reproduce:
1.Check RAID1 mapping table created via "dmraid -tay"
  
Actual results:
Table doesn't contain the handle_errors argument.

Expected results:
Table does contain it.

Additional info:
Comment 1 Ian Kent 2007-11-13 23:14:15 EST
Created attachment 257681 [details]
Patch to add handle_error argument
Comment 2 RHEL Product and Program Management 2007-11-13 23:24:22 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 Peter Jones 2008-02-06 18:00:11 EST
This change completely breaks RAID 1 in 5.2 -- the kernel does not support
handle_errors.
Comment 8 Ian Kent 2008-02-08 13:19:40 EST
I can't get information about this this kernel
issue in time so I have to go with reverting the
patch.

Setting the request flags to reflect that.

Ian
Comment 9 RHEL Product and Program Management 2008-06-02 16:28:15 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 10 Heinz Mauelshagen 2008-12-10 13:41:29 EST
This has been addressed in 5.3, closing.

The table syntax differs between upstream and RHEL5 kernel because of the differences in error handling processing:

upstream kernel takes handle_errors as a mirror argument
*whereas*
RHEL5 kernel expects block_on_error as a dirty log argument.

Note You need to log in before you can comment on or make changes to this bug.