This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 38151 - Kylix does not install on RH 7.1 because of bash2.04
Kylix does not install on RH 7.1 because of bash2.04
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: bash (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
www.borland.com/kylix
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-27 23:08 EDT by Hakan TERZIOGLU
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-30 16:10:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kylix after install script =that has a problem (15.56 KB, text/plain)
2001-04-30 16:10 EDT, Hakan TERZIOGLU
no flags Details

  None (edit)
Description Hakan TERZIOGLU 2001-04-27 23:08:11 EDT
Kylix installer from Loki Games, crashes on RH7.1 after installing main
package RPM.
Because it can not successfully execute post install script main.sh on
/CD_ROOT/setup.data/
the main.sh script (bash script) has -eq -gt operators which causes bash to
have this output :

main.sh: [: -gt: unary operator expected
main.sh: [: -eq: unary operator expected

No Problem with 6.2, 7.0 with glibc patches done. Also no problem on
linux-Mandrake 8.0
nor Suse 7.1.
Comment 1 Bernhard Rosenkraenzer 2001-04-30 12:55:29 EDT
Please attach the script - can't figure out exactly what's going wrong without 
seeing what they're trying to do.
Comment 2 Bernhard Rosenkraenzer 2001-04-30 13:15:44 EDT
I have passed this on to the Inprise bug tracking system; reference number is 
463612.

Since -gt and -eq work perfectly in bash 2.04, I think this is related to 
something else they're trying to do. It's almost certainly a case of

BLAH=`something that doesn't work and returns an empty value`
if [ $BLAH -gt 2 ]; then
	something
fi

Most likely, it's a hardcoded /usr/bin/cut somewhere; cut has moved to /bin.

Comment 3 Hakan TERZIOGLU 2001-04-30 16:10:03 EDT
Created attachment 16888 [details]
Kylix after install script =that has a problem
Comment 4 Bernhard Rosenkraenzer 2001-04-30 16:32:13 EDT
Ok, I'm now absolutely certain it's their bug and not ours. Their chklibc tool 
returns an empty value.
Please report this to Borland/Inprise, we can't fix up their proprietary code.


Note You need to log in before you can comment on or make changes to this bug.