Bug 381541 - F8 Transition to Anaconda produces pcidom error and kills install on PS3
Summary: F8 Transition to Anaconda produces pcidom error and kills install on PS3
Status: CLOSED DUPLICATE of bug 370761
Alias: None
Product: Fedora
Classification: Fedora
Component: rhpxl
Version: 8
Hardware: powerpc
OS: Linux
low
low
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-14 04:38 UTC by Greg Morgan
Modified: 2007-11-30 22:12 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2007-11-15 23:27:04 UTC


Attachments (Terms of Use)

Description Greg Morgan 2007-11-14 04:38:49 UTC
Description of problem:

Received a traceback on PS3 firmware 2.0 PPC with f8 installation.  I had to 
transcribe the message because ALT F[1-7] function keys were not usable.

Google reports similar problems
http://julipedia.blogspot.com/2007/10/got-it-ps3.html#c7668625964381266145
http://julipedia.blogspot.com/2007/10/got-it-ps3.html#c1098426015556577328


Traceback follows:

Running anaconda 11.3.0.50 the Fedora system installer - please wait.

Traceback (most recent call last)
File"/usr/bin/anaconda", line 779, in < module>
  floppy Device = probeHW(opts, x_already_set, xserver)
File /usr/bin/anaconda line 421, in prowbeHW
  xserver.probeHW(skipMouseProbe = skipmouseprobe, forceDriver = opts.xdriver)
 File "/usr/lib/python2.5/site_packages/rhpxl/xserver.py", line 87 in probeHW
self.videohw = videocard.VideoCardInfo (forceDriver = forceDriver)
File "/usr/lib/python2.5/site_packages/rhpxl/videocard.py", line 149, in 
__init__
elif osname()[4].count("ppc" ) > 0 and cmd.pcidom > 0:
  Atribute Error device instance has no attribute 'pcidom'
install exited abnormally[1/1]
 sending termination signals ... done.

...

Version-Release number of selected component (if applicable):
11.3.0.50

How reproducible:
Each time the f8 installation is attempted.

Steps to Reproduce:
1. I updated to PS3 firmware 2.0.
2. I created sha1sumed the PPC*iso files.  After burning the media I verified 
the media for f8 on DVD.  I also attempted a boot.iso and NFS server install.
3. I installed the kexec module as per RFE bug 235612.  I had to use the 
otheros.bld file from http://ozlabs.org/~jk/projects/petitboot/ because the 
version here http://david.woodhou.se/otheros.bld is "corrupt". ( I sent an 
email to David)
4. This was successful because I was able to boot into text mode anaconda.
5. After all all the stage one information was entered, the transition to 
anaconda produced a pcidom trace back.
  
Actual results:
Failed to install f8 on PS3 PPC hardware.

Expected results:
Installation of f8 on PS3.

Additional info:
Is there some additional hardware information that you'd like me to attach in 
order to solve or investigate the error?

Comment 1 Greg Morgan 2007-11-15 23:27:04 UTC

*** This bug has been marked as a duplicate of 374201 ***

Comment 2 Greg Morgan 2007-11-15 23:30:09 UTC

*** This bug has been marked as a duplicate of 370761 ***

*** This bug has been marked as a duplicate of 370761 ***


Note You need to log in before you can comment on or make changes to this bug.