Bug 381621 - PS3 fails in mounting non-LVM root fs on internal hard disk drive
PS3 fails in mounting non-LVM root fs on internal hard disk drive
Status: CLOSED DUPLICATE of bug 389331
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
ppc64 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-14 00:39 EST by Kazunori Asayama
Modified: 2008-02-13 21:37 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-13 21:37:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kazunori Asayama 2007-11-14 00:39:45 EST
Description of problem:

  PS3 fails in mounting non-LVM root filesystem on its internal hard disk drive
/dev/ps3d*. It looks like that the initrd can't recognize labels of non-LVM
partitions on PS3's internal HDD, and if replacing 'root=LABEL=/' in yaboot.conf
with 'root=/dev/ps3da2' etc, the root filesystem can be mounted normally.


Version-Release number of selected component (if applicable):

  kernel-2.6.23.1-42.fc8
  kernel-2.6.23.1-49.fc8

  mkinitrd-6.0.19-4.fc8


How reproducible:

  Everytime.


Steps to Reproduce:
1. Install F8 onto PS3 with non-LVM root filesystem.
2. Boot PS3.


Actual results:

Red Hat nash version 6.0.19 starting
Unable to access resume device (LABEL=SWAP-ps3da2)
mount: could not find filesystem '/dev/root'
setuproot: moving /dev failed: No such file or directory
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
setuproot: mount failed: No such file or directory


Expected results:

  PS3 boots normally with non-LVM root filesystem.


Additional info:
Comment 1 Christopher Brown 2008-02-13 17:05:41 EST
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few weeks if there is no additional information lodged.
Comment 2 Kazunori Asayama 2008-02-13 21:37:00 EST
(In reply to comment #1)
This bug is the same one as #389331, so I'll mark this as duplicate of that.


*** This bug has been marked as a duplicate of 389331 ***

Note You need to log in before you can comment on or make changes to this bug.