Bug 381691 - Built-in audio controller not recognized due to USB Audio headset
Summary: Built-in audio controller not recognized due to USB Audio headset
Status: CLOSED DUPLICATE of bug 232217
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 8
Hardware: i586
OS: Linux
low
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-14 06:45 UTC by Dimi Paun
Modified: 2008-01-14 09:56 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-14 09:56:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
system-config-soundcard log for a non-working system (51.86 KB, text/plain)
2007-11-14 06:45 UTC, Dimi Paun
no flags Details
system-config-soundcard log for a working system (via workaround) (55.53 KB, text/plain)
2007-11-14 06:57 UTC, Dimi Paun
no flags Details
A unified diff between the non-working and working system scsconfig.log's. (21.67 KB, text/plain)
2007-11-14 06:59 UTC, Dimi Paun
no flags Details

Description Dimi Paun 2007-11-14 06:45:37 UTC
Description of problem:
Sound fails to work on a standard 
Intel Corporation 82801H (ICH8 Family) HD Audio Controller 

I have complained about this problem since FC6 or earlier,
and was told to report it upstream to ALSA folks.

However, now I have firm reason to believe this is a kernel
related problem.

Version-Release number of selected component (if applicable):
Linux 2.6.23.1-42.fc8 #1 SMP Tue Oct 30 13:55:12 EDT 2007 i686 i686 i386 GNU/Linux

How reproducible:
After most reboots, sound fails to work.

Steps to Reproduce:
1. Insert Plantronics Headset into USB port.
2. Reboot

Actual results:
Sound is most likely (not always, but 90% of time) not
working on the built-in Intel 82801H/ICH8 Audio Controller.
Running system-config-soundcard lists only the USB headset,
not the Intel controller.

Expected results:
Both the USB headset and built-in Intel controller should be
available.

Additional info:
To work around it, I have to unplug the USB headset, reboot,
now the Intel Controller gets recognized, then insert the headset
into the USB port.

It seems that snd_usb_audio module can not be unloaded, and that
prevents the Intel card from being recognized.

I will attach the system-config-soundcard logs for edification.

Comment 1 Dimi Paun 2007-11-14 06:45:37 UTC
Created attachment 257751 [details]
system-config-soundcard log
for a non-working system

Comment 2 Dimi Paun 2007-11-14 06:57:41 UTC
Created attachment 257761 [details]
system-config-soundcard log for a working system (via workaround)

This log shows what happens if I boot the system without
the USB headset, and insert it _after_ the boot.

Comment 3 Dimi Paun 2007-11-14 06:59:44 UTC
Created attachment 257771 [details]
A unified diff between the non-working and working system scsconfig.log's.

A diff -u of the previously uploaded files (attachments 257751 and 257761).

Comment 4 Per Thomas Jahr 2007-11-15 11:40:33 UTC
Same happens for me. In dmesg there was something like "cannot find the slot 
for index 0". 

Workaround: boot without the USB headset, insert USB headset, go into system-
config-soundcard and rearrange the cards so that the built-in controller is the 
first one.

It seems that the use of index 0 for the built-in controller was specified in 
the modprobe.conf file.

Comment 5 David Campbell 2007-11-19 12:01:06 UTC
I have a notebook with an internal USB TV Tuner with USB audio [input only].

I cannot work around the problem.

I see similar trouble and the following in my dmesg....

cannot find the slot for index 0 (range 0-0), error: -16
Intel ICH: probe of 0000:00:1f.5 failed with error -12



Comment 6 David Campbell 2007-11-19 12:13:48 UTC
Adding the following to /etc/modprobe.conf seems to have helped in my case.  The
installer for f7 had automatically put this in, but the f8 installer hadn't.

alias snd-card-1 snd-usb-audio
options snd-usb-audio index=1

The entries for snd-card-0 and snd-intel8x0 are already present.


Comment 7 Dimi Paun 2007-11-19 14:48:11 UTC
Speaking of which, here is my /etc/modprobe.conf (this is the default one, I
didn't touch it):

alias eth0 skge
alias eth1 sky2
alias scsi_hostadapter ahci
alias snd-card-0 snd-hda-intel
options snd-card-0 index=0
options snd-hda-intel index=0
#remove snd-hda-intel { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-hda-intel
# nvidia kernel module
alias char-major-195 nvidia-100_14_19
alias nvidia nvidia-100_14_19


Now, if the intel card is specified at index 0, why would the USB one
be inserted before it?
And why is the "remove snd-hda-intel" commented out? I don't recall doing
it, but then again, I always tend to upgrade the system rather than reinstall,
and I don't know if anaconda rewrites this file at all... 


Comment 8 Hans de Goede 2008-01-14 09:56:31 UTC
This is not a kernel issue, but rather a userspace configuration issue, to be
precise its is a dup of bug 232217, closing as such.


*** This bug has been marked as a duplicate of 232217 ***


Note You need to log in before you can comment on or make changes to this bug.