Bug 38172 - anaconda syntax error
anaconda syntax error
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-28 00:49 EDT by Jim Fugate
Modified: 2008-08-01 12:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:38:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error from expert mode (photo) (1.03 MB, image/png)
2001-04-28 09:04 EDT, Chris Jones
no flags Details

  None (edit)
Description Jim Fugate 2001-04-28 00:49:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; AtHome021SI)


Running install by booting from CD.  Kernel loads, get blue screen, then:
Running anaconda - please wait ...
  File "/usr/bin/anaconda", line 4
     signal.signal(signal SIGINT, signal.SIG_DFL)
          ^
  SyntaxError: invalid syntax
  install exited abnormally
  sending termination signals ... done
  sending kill signals ... done
  disabling swap ...
  unmounting filesystems ...
    /proc/bus/usb
    /mnt/runtime
    /mnt/source  unmount failed ()
    /dev/pts
    /proce
you may safely reboot your system

Reproducible: Always
Steps to Reproduce:
1.Start install from CD.
2.Press enter at boot: (also, expert and text fail)
3.
	

Actual Results:  Got error message listed above.  SyntaxError in anaconda.

Expected Results:  System should have continued install.

<Ctrl>+<Alt>+<F4> last message was "Cannot determine CD format"
This is same machine I have run RH 6.0, 6.1 and currently 7.0.  Those 
installs worked fine.
Comment 1 Chris Jones 2001-04-28 09:04:52 EDT
Created attachment 16705 [details]
Error from expert mode (photo)
Comment 2 Chris Jones 2001-04-28 09:14:23 EDT
Mode 'nofb' install also fails.

Tyan Trinity 400 - S1854 motherboard
VIA Pro 133A (694X) chipset
Intel Celeron 366
96MB RAM
Samsung CD-ROM (Model: CD-ROM SCR-2432 Rev: T104)
Diamond Stealth III S540 video (Savage4)

Same CD installed succesfully onto ABit Athlon system and Dell Dimension 4100.
Comment 3 Jim Fugate 2001-04-28 10:12:16 EDT
I checked my CD-ROM.  It is Samsung SCR-2432 as well.
Comment 4 Brent Fox 2001-04-30 10:52:36 EDT
Can you try making a boot floppy off the boot.img file in the /images directory?
 Boot off that floppy, and then select CDROM as the installation media.  Does
this fix the problem?
Comment 5 Brent Fox 2001-05-10 15:53:28 EDT
Closing due to inactivity.  Please reopen if you have more information.
Comment 6 Jeff Silverman 2001-07-09 02:18:46 EDT
Hi, my name is Jeff Silverman and I have a problem installing RH7.1 on an E-machines PC

This machine has an E-machines Etower 300c with an Authentic AMD 300 MHZ K6-3D processor and 128
MBytes of RAM.  It has a Samsung CD-ROM SCR-2432 and a VIA chipset and a RealTek RTL8029 Ethernet
adapter.

When I do an RH 7.1 installation in either text, default (graphical), expert, or nofb modes, I get a
syntax error from /usr/bin/anaconda at line 4:
    signal.signal ( signal.SIGINT, signal.SIG_DFL)

which is invalid.


I understand that you closed this bug due to lack of activity.  I'd like to work with you on this, if you are willing.


Many thanks,


Jeff Silverman

jeffs@commercialventvac.com
Comment 7 Brent Fox 2001-07-11 13:10:36 EDT
Ok, I'm reopening the bug.  Jeff, have you tried booting off the boot.img floppy
and then using the cd?
Comment 8 Jeff Silverman 2001-07-15 04:48:52 EDT
I am having problems booting off of the floppy drive.  I am still working on the 
problem.

Sorry.

Jeff
Comment 9 Jim Fugate 2001-07-16 20:21:48 EDT
I'm back.  I originally reported the bug. 
I don't think it is possible to boot off floppy in RedHat 7.1.  I don't know if
this is related, but I cannot format a floppy in 7.1 either.  gfloppy in GNOME
cannot format floppy, "Floppy Formatter" in KDE 2.1.2 cannot format, RedHat
install cannot make boot disk, mkbootdisk fails.  I even bought new box of
pre-formated floppies and it still doesn't work.  Reboot either machine into
Windoze, and the format works fine (Win98 and WinME).  I even formatted disk in
Windoze, then rebooted into RedHat 7.1 and could not format same floppy.  This
is the same with both my E-machine and NEC computers.  According to
/proc/ide/drivers the version is "ide-floppy version 0.97"  

My machines are as follows:

1. E-machines 333k with AMD K6-2 333mhz, VIA Technologies, Inc. VT82C598 [Apollo
MVP3] (rev 4)( from /proc/pci ). 

2. NEC Ready 9701 with Intel Pentium 150Mhz. Intel 430VX - 82437VX [Triton VX]
(Rev. 2) ( from /proc/pci ).

The E-machine CD-ROM does not work.  The CD-ROM from the NEC does.  Here are the
configurations from both machines for comparison.

E-machine (non-working CD-ROM):

/proc/ide/ide1/hdc/model file reads SAMSUNG CD-ROM SCR-2432.
/proc/ide/ide1/hdc/driver file reads ide-cdrom version 4.59.

NEC Ready 9701 (working CD-ROM):

/proc/ide/ide1/hdc/model file reads CRD-8160B (Goldstar CD-ROM I think)    
/proc/ide/ide1/hdc/driver file reads (none)  (Interesting!)

Thanks for looking into this.

Jim Fugate
Comment 10 Jeff Silverman 2001-07-17 03:42:24 EDT
Nice work, Jim.  I had the same problem but I didn't make the leap to conclude that the problem is in RH 7.1.  I assumed hardware problems.  In 
particular, once the floppy has been written, mkbootdisk can't seem to rewrite it.  It throws an I/O error.  

I tried building the floppy on a couple of different machines.  I've built a boot floppy under Windows/95 using Rawrite, but I assumed that there was a 
problem so I overwrote it.  I wish I hadn't done that.  Finally, I built a floppy on a server which is something of a mongrel 6.2, and when I tried to boot from 
the floppy, I got an error that it was trying to read beyond the end of the device, and then it kernel panics.  

I also have an E-machines, e tower 300c with an Authentic AMD K-6 3d cpu and 128 MBytes of RAM and a VIA tech V82C598 chipset.

I tried building a boot floppy on elvis and succeeded. Finally. I tested it by booting elvis, which almost worked. Elvis has an old SCSI controller. I
tried it on six and I get kernel panics pretty consistently. I think I might have a bad floppy drive. 

I seem to recall a comment about using the nodma parameter to the linux boot prompt. I found more information at
http://uwsg.iu.edu/hypermail/linux/kernel/0103.1/0043.html. I found the same information in the redhat development list at 
http://www.geocrawler.com/archives/3/84/2001/5/0/5830733/

Try booting with 
linux ide0=dma ide1=nodma
I thought this would work because the disks are on the IDE0 bus and the CD-ROM is on the IDE1 bus. But it also failed.

I am tempted to take the HD to a different machine and cross build Linux on it, but I think I'm going to hold off that because I want to help resolve this 
problem.

Comment 11 Jim Fugate 2001-07-17 08:22:44 EDT
OK, OK forgive my ignorance.  I went back and re-tested the data I provided last
night and found that the Intel 430VX chip set machine WILL format floppies now.
 I have upgraded from 2.4.2 kernel to the 2.4.3 kernel since trying all the
things mentioned.  The E-machines VIA Technologies, Inc. VT82C598 [Apollo MVP3]
(rev 4) machine still fails.  When attempt to format with gfloppy I get "Unable
to write to floppy. Please check that it is not write protected."  I formatted
successfully on NEC Intel chip machine, then took same floppy to E-machine VIA
chip machine and it fails.  I can boot into Win98 and if formats successfully.

Sorry for not re-testing after kenel upgrade before opening my mouth.  Hope it
didn't cause to much confusion.

Comment 12 Brent Fox 2001-07-18 14:30:56 EDT
Well, I'm fairly certain that floppys work in 7.1.  I make boot disks almost
every day with mine, as well as anaconda update floppys.  I'm just guessing, but
it sounds like both of you are seeing some hardware problems.
Comment 13 Jim Fugate 2001-07-18 18:18:44 EDT
I am currently writing from same "problem" machine.  E-machine with VIA chip 
set running in Win98.  I just formatted the same floppy I was testing with in 
RH 7.1.  This is same machine I had NO problems with in RH 5.2, 6.0, 6.1 and 
7.0.  Now with RH 7.1 I have problems formatting floppies and anaconda has 
problems with reading the CD.  I could backup data and re-install older RH 
version for additional testing if you need me to ( I would rather not, but if 
it will help, I will).
Comment 14 Matt Wilson 2001-07-20 17:16:40 EDT
This is data corruption.  Boot with ide=nodma.  After the system installs, send
the results of:

for I in /proc/ide/hd*; do echo $I; cat $I/model; done
Comment 15 Jim Fugate 2001-07-20 20:59:32 EDT
Done.  Here is output:

/proc/ide/hda
ST33210A
/proc/ide/hdb
Maxtor 91366U4
/proc/ide/hdc
SAMSUNG CD-ROM SCR-2432

ST33210A  is Seagate 3.2Gig (lilo dual boot. Drive contains only Win98 and lilo)
Maxtor 91366U4 is 13.4Gig (RH7.1 drive)

I tried formatting floppy with ide=nodma boot parameter with same results.  

Another note after re-reading my input.  When I mentioned "E-machine CD-ROM
(does not work)", I am referring to the syntax error during anaconda install
only.  Now that system is up and running.  CD works as expected.
Comment 16 Jim Fugate 2001-07-20 21:11:43 EDT
While we are at it.  Maybe this is related.  GnoRPM freaks out when I do "Find",
"match label", enter package name, "Find", highlight "Found" package, "Query". 
All I get is small, empty window labeled "Package Info".  This is consistent on
2 machines and only started in RH7.1.  
I don't mean to muddy the waters here, but it might be somehow related.
Comment 17 Bugzilla owner 2004-09-30 11:38:58 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.