Bug 381721 - Package Updater (PUP) is asking to insert CD
Summary: Package Updater (PUP) is asking to insert CD
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 8
Hardware: All Linux
low
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Fedora Extras Quality Assurance
URL: http://tchung.fedorapeople.org/F8_Err...
Whiteboard:
Keywords:
Depends On:
Blocks: F9Blocker
TreeView+ depends on / blocked
 
Reported: 2007-11-14 07:50 UTC by Thomas Chung
Modified: 2008-03-27 19:34 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-27 19:34:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thomas Chung 2007-11-14 07:50:22 UTC
1. Fresh F8 DVD Install
2. Launching Package Updater (PUP) for the first time
3. It's asking to insert CD

See a screenshot at
http://tchung.fedorapeople.org/F8_Errata/F8_Errata_Insert_CD.png

Comment 1 Jeremy Katz 2007-11-14 15:22:02 UTC
Yep, that's so we can read the metadata off of it to use later for depsolving.

What we should do in Fedora 9 is also copy the metadata off of the CD as part of
the install process.  I'd go ahead and write the relatively simple code for it,
but Chris is in the middle of making changes to that code, so I'm better off
waiting until he's done.  

Comment 2 Will Woods 2007-11-15 17:32:00 UTC
To work around this, either disable the InstallMedia repo or just insert the
DVD. It should stop asking after it reads the DVD the first time.


Comment 3 Jeremy Katz 2007-11-16 16:35:21 UTC
Correct

Comment 4 Jeremy Katz 2008-02-05 20:58:10 UTC
Added to anaconda and pushed to git

Comment 5 Will Woods 2008-03-27 19:34:24 UTC
User confirmed that, after install of F9Beta from DVD, pirut did not request
media or crash or anything.

Also note that since PackageKit is replacing pirut, this is slightly less of a
concern. pk-application also seemed to DTRT. 


Note You need to log in before you can comment on or make changes to this bug.