Bug 381831 - prefdm seems to fail?
Summary: prefdm seems to fail?
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-14 09:01 UTC by Jens Petersen
Modified: 2008-02-06 23:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-06 23:33:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jens Petersen 2007-11-14 09:01:45 UTC
Description of problem:
Not quite sure what the issue is, but in rawhide prefdm seems to be failing
now.  Maybe it is not initscripts fault, since it is unchanged from f8?
So may be related to the new gdm?

This is also causing prefdm to spawn too quickly at runlevel 5.

How reproducible:
every time

Steps to Reproduce:
1. Run prefdm from console
  
Actual results:
nothing

Expected results:
prefdm to start gdm

Additional info:
Funnily enough if I add "set -x" to the prefdm script it seems to work for me??

Comment 1 Bill Nottingham 2007-11-14 17:04:35 UTC
Does it work with non-gdm display managers?

Comment 2 Bill Nottingham 2007-11-14 18:49:07 UTC
It's gdm. Disabling SELinux lets it get a bit further.

Comment 3 Felix Bellaby 2007-11-22 23:59:01 UTC
Part of this problem seems to come from the selinux context on /etc/X11/prefdm

/sbin/init has context init_exec_t
/etc/X11/prefdm has context initrc_exec_t
/usr/sbin/gdm has context xdm_exec_t

selinux allows a transition from init_ext_t -> xdm_exec_t

However it prevents a transition from initrc_exec_t -> xdm_exec_t

If you change the context of prefdm to xdm_exec_t or init_exec_t then you can at
least start gdm using prefdm.


Comment 4 Jens Petersen 2008-02-06 23:33:24 UTC
This has been fixed now for quite a while.


Note You need to log in before you can comment on or make changes to this bug.