Bug 381861 - nedit crashes when pasting data with ctrl-v
nedit crashes when pasting data with ctrl-v
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: nedit (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: c->xlib.lock
  Show dependency treegraph
 
Reported: 2007-11-14 04:08 EST by Gert Vervoort
Modified: 2013-07-02 19:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-31 07:14:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdb backtrace of nedit assertion failure (2.47 KB, text/plain)
2007-12-06 04:23 EST, Edward Sheldrake
no flags Details

  None (edit)
Description Gert Vervoort 2007-11-14 04:08:05 EST
Description of problem:

When pasting information into nedit, it crahses with the following error message :

[gert@apollo tmp]$ nedit 
nedit: the current locale is utf8 (en_US.UTF-8)
nedit: changed locale to non-utf8 (en_US)
nedit: xcb_xlib.c:41: xcb_xlib_lock: Assertion `!c->xlib.lock' failed.
Aborted
[gert@apollo tmp]$ 


Version-Release number of selected component (if applicable):

nedit.x86_64                             5.5-12.fc8             installed  

How reproducible:

always

Steps to Reproduce:
1. start nedit
2. copy some data to the clipboard with crtl-c (e.g. a URL in firefox)
3. paste the data to nedit with ctrl-v
  
Actual results:

nedit crashes with error message "xcb_xlib_lock: Assertion `!c->xlib.lock' failed":

[gert@apollo tmp]$ nedit 
nedit: the current locale is utf8 (en_US.UTF-8)
nedit: changed locale to non-utf8 (en_US)
nedit: xcb_xlib.c:41: xcb_xlib_lock: Assertion `!c->xlib.lock' failed.
Aborted
[gert@apollo tmp]$


Expected results:

The data from the clipboard bying pasted in the nedit editor window.

Additional info:
Comment 1 Martin A. Boegelund 2007-11-14 10:18:27 EST
I get the same error message when I try to run the BOINC manager
(http://boinc.berkeley.edu/).

Others get the same error in BOINC, and as I read the support case, it's an
error in the libxcb package (http://boinc.berkeley.edu/trac/ticket/432).

A workaround for openSUSE is provided (http://en.opensuse.org/Xlib.lock), but it
doesn't work for me.

My system is x86 (Celeron) based.
Comment 2 nathan r. hruby 2007-11-18 13:01:38 EST
I'll add a METOO for the Citrix client (hey, it's better than running Windows
:).  I also had the Java problem as well, but the s/XINERAMA/FAKEEXT/ trick from
Bug 254144 seems to have mostly resolved the issue.  

It appears that the XCB stuff [1] in libX11 causes some software to barf?  I see
several other bugs in RH Bugzilla against f8 about this same symptom.  Perhaps
we should have a tracking bug for this issue and mark these as dupes of that?

Also, if we could have a temporary workaround similar to SuSe's hack until more
packages can converge on fixing their bugs -- that'd be super handy.

1 - http://lists.debian.org/debian-devel-announce/2006/11/msg00010.html
Comment 3 Jindrich Novy 2007-11-19 07:38:52 EST
Yes, you are right. It seems like libX11 needs to be fixed first and bug 301691
looks like a good tracker for these issues.
Comment 4 Jindrich Novy 2007-11-19 07:39:21 EST

*** This bug has been marked as a duplicate of 301691 ***
Comment 5 Matěj Cepl 2007-11-19 07:56:13 EST
No, that's not the bug we were talking about. It should be reopened and bug
390621 is just a tracking bug.
Comment 6 Edward Sheldrake 2007-12-06 04:23:21 EST
Created attachment 279491 [details]
gdb backtrace of nedit assertion failure

I think this bug should be reassigned to lesstif since you can get the same
assertion failure when pasting into ddd. I've attached the gdb backtrace of the
first assertion failure with nedit.

NB - The work around does work for me, and there are several more assertion
failures after the first if nedit isn't aborted.

My hardware is x86 (32 bit).
Comment 7 Jindrich Novy 2007-12-06 04:53:28 EST
The only thing that should be enough to fix this is to update libxcb in F8 to
1.1. Tried it out a few days ago and it fixed the assertion problems for me
(x86_64).
Comment 8 Douglas Wooster 2007-12-30 17:02:45 EST
Bug 301691 reported that libxcb-1.0-4.fc8 was available with a fix to the Java
flavor of this problem.  I just tested libxcb-1.0-4.fc8 and it fixes the nedit
paste crash, also.
Comment 9 Gert Vervoort 2007-12-31 05:14:09 EST
Indeed, the update to libxcb fixes the paste bug.

[gert@apollo tmp]$ yum list | grep libxcb
libxcb.x86_64                            1.0-4.fc8              installed       
libxcb-devel.x86_64                      1.0-4.fc8              installed       
libxcb.i386                              1.0-4.fc8              updates         
libxcb-devel.i386                        1.0-4.fc8              updates         
libxcb-doc.x86_64                        1.0-4.fc8              updates         
[gert@apollo tmp]$ 
Comment 10 Jindrich Novy 2007-12-31 07:14:43 EST
Ok, closing ERRATA then.

Note You need to log in before you can comment on or make changes to this bug.