Bug 382141 - gtksharp doesn't build
gtksharp doesn't build
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gtk-sharp (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Paul F. Johnson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-14 06:18 EST by Jay Turner
Modified: 2015-01-07 19:16 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-08 15:25:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubomir Kundrak 2007-11-14 06:18:56 EST
Description of problem:

sh: line 0: fg: no job control
Building target platforms: i686
Building for target i686
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.23328
+ umask 022
+ cd /usr/src/redhat/BUILD
+ LANG=C
+ export LANG
+ unset DISPLAY
+ cd /usr/src/redhat/BUILD
+ rm -rf gtk-sharp-1.0.10
+ /bin/gzip -dc /usr/src/redhat/SOURCES/gtk-sharp-1.0.10.tar.gz
+ tar -xf -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd gtk-sharp-1.0.10
+ echo 'Patch #0 (gtksharp-libdir.patch):'
Patch #0 (gtksharp-libdir.patch):
+ patch -p1 -b --suffix .libdir -s
+ autoreconf
/usr/share/aclocal/dynamite.m4:4: warning: underquoted definition of
AM_PATH_LIBDYNAMITE
/usr/share/aclocal/dynamite.m4:4:   run info '(automake)Extending aclocal'
/usr/share/aclocal/dynamite.m4:4:   or see
http://sources.redhat.com/automake/automake.html#Extending-aclocal
art/Makefile.am:28: addprefix $(srcdir: non-POSIX variable name
art/Makefile.am:28: (probably a GNU make extension)
art/Makefile.am:33: addprefix $(srcdir: non-POSIX variable name
art/Makefile.am:33: (probably a GNU make extension)
atk/Makefile.am:19: addprefix $(srcdir: non-POSIX variable name
atk/Makefile.am:19: (probably a GNU make extension)
atk/Makefile.am:23: addprefix $(srcdir: non-POSIX variable name
atk/Makefile.am:23: (probably a GNU make extension)
doc/updater/Makefile.am:11: addprefix $(srcdir: non-POSIX variable name
doc/updater/Makefile.am:11: (probably a GNU make extension)
gconf/GConf.PropertyEditors/Makefile.am:33: addprefix $(srcdir: non-POSIX
variable name
gconf/GConf.PropertyEditors/Makefile.am:33: (probably a GNU make extension)
gconf/GConf/Makefile.am:35: addprefix $(srcdir: non-POSIX variable name
gconf/GConf/Makefile.am:35: (probably a GNU make extension)
gda/Makefile.am:28: addprefix $(srcdir: non-POSIX variable name
gda/Makefile.am:28: (probably a GNU make extension)
gda/Makefile.am:33: addprefix $(srcdir: non-POSIX variable name
gda/Makefile.am:33: (probably a GNU make extension)
gdk/Makefile.am:41: addprefix $(srcdir: non-POSIX variable name
gdk/Makefile.am:41: (probably a GNU make extension)
gdk/Makefile.am:65: addprefix $(srcdir: non-POSIX variable name
gdk/Makefile.am:65: (probably a GNU make extension)
generator/Makefile.am:55: addprefix $(srcdir: non-POSIX variable name
generator/Makefile.am:55: (probably a GNU make extension)
glade/Makefile.am:32: addprefix $(srcdir: non-POSIX variable name
glade/Makefile.am:32: (probably a GNU make extension)
glade/Makefile.am:37: addprefix $(srcdir: non-POSIX variable name
glade/Makefile.am:37: (probably a GNU make extension)
glib/Makefile.am:50: addprefix $(srcdir: non-POSIX variable name
glib/Makefile.am:50: (probably a GNU make extension)
gnome/Makefile.am:34: addprefix $(srcdir: non-POSIX variable name
gnome/Makefile.am:34: (probably a GNU make extension)
gnome/Makefile.am:71: addprefix $(srcdir: non-POSIX variable name
gnome/Makefile.am:71: (probably a GNU make extension)
gnomedb/Makefile.am:28: addprefix $(srcdir: non-POSIX variable name
gnomedb/Makefile.am:28: (probably a GNU make extension)
gnomedb/Makefile.am:32: addprefix $(srcdir: non-POSIX variable name
gnomedb/Makefile.am:32: (probably a GNU make extension)
gtk/Makefile.am:29: addprefix $(srcdir: non-POSIX variable name
gtk/Makefile.am:29: (probably a GNU make extension)
gtk/Makefile.am:98: addprefix $(srcdir: non-POSIX variable name
gtk/Makefile.am:98: (probably a GNU make extension)
gtkhtml/Makefile.am:27: addprefix $(srcdir: non-POSIX variable name
gtkhtml/Makefile.am:27: (probably a GNU make extension)
gtkhtml/Makefile.am:33: addprefix $(srcdir: non-POSIX variable name
gtkhtml/Makefile.am:33: (probably a GNU make extension)
pango/Makefile.am:20: addprefix $(srcdir: non-POSIX variable name
pango/Makefile.am:20: (probably a GNU make extension)
pango/Makefile.am:35: addprefix $(srcdir: non-POSIX variable name
pango/Makefile.am:35: (probably a GNU make extension)
parser/Makefile.am:12: addprefix $(srcdir: non-POSIX variable name
parser/Makefile.am:12: (probably a GNU make extension)
rsvg/Makefile.am:29: addprefix $(srcdir: non-POSIX variable name
rsvg/Makefile.am:29: (probably a GNU make extension)
rsvg/Makefile.am:33: addprefix $(srcdir: non-POSIX variable name
rsvg/Makefile.am:33: (probably a GNU make extension)
sample/GtkDemo/Makefile.am:2: addprefix /r:, $(assemblies: non-POSIX variable name
sample/GtkDemo/Makefile.am:2: (probably a GNU make extension)
sample/GtkDemo/Makefile.am:4: addsuffix .mdb, $(TARGETS: non-POSIX variable name
sample/GtkDemo/Makefile.am:4: (probably a GNU make extension)
sample/GtkDemo/Makefile.am:60: addprefix $(srcdir: non-POSIX variable name
sample/GtkDemo/Makefile.am:60: (probably a GNU make extension)
sample/GtkDemo/Makefile.am:61: addprefix $(srcdir: non-POSIX variable name
sample/GtkDemo/Makefile.am:61: (probably a GNU make extension)
sample/GtkDemo/Makefile.am:62: addprefix /resource:, $(build_sources: non-POSIX
variable name
sample/GtkDemo/Makefile.am:62: (probably a GNU make extension)
sample/Makefile.am:30: addprefix /r:, $(assemblies: non-POSIX variable name
sample/Makefile.am:30: (probably a GNU make extension)
sample/Makefile.am:32: addsuffix .mdb, $(TARGETS: non-POSIX variable name
sample/Makefile.am:32: (probably a GNU make extension)
sample/gconf/Makefile.am:14: addprefix /r:, $(ASSEMBLIES: non-POSIX variable name
sample/gconf/Makefile.am:14: (probably a GNU make extension)
sample/gconf/Makefile.am:27: use `install-data-hook' or `install-exec-hook', not
`install-hook'
sample/rsvg/Makefile.am:2: addprefix /r:, $(assemblies: non-POSIX variable name
sample/rsvg/Makefile.am:2: (probably a GNU make extension)
sample/GtkDemo/Makefile.am:4: addsuffix .mdb, $(TARGETS: non-POSIX variable name
sample/GtkDemo/Makefile.am:4: (probably a GNU make extension)
sample/GtkDemo/Makefile.am:60: addprefix $(srcdir: non-POSIX variable name
sample/GtkDemo/Makefile.am:60: (probably a GNU make extension)
sample/GtkDemo/Makefile.am:61: addprefix $(srcdir: non-POSIX variable name
sample/GtkDemo/Makefile.am:61: (probably a GNU make extension)
sample/GtkDemo/Makefile.am:62: addprefix /resource:, $(build_sources: non-POSIX
variable name
sample/GtkDemo/Makefile.am:62: (probably a GNU make extension)
sample/Makefile.am:30: addprefix /r:, $(assemblies: non-POSIX variable name
sample/Makefile.am:30: (probably a GNU make extension)
sample/Makefile.am:32: addsuffix .mdb, $(TARGETS: non-POSIX variable name
sample/Makefile.am:32: (probably a GNU make extension)
sample/gconf/Makefile.am:14: addprefix /r:, $(ASSEMBLIES: non-POSIX variable name
sample/gconf/Makefile.am:14: (probably a GNU make extension)
sample/gconf/Makefile.am:27: use `install-data-hook' or `install-exec-hook', not
`install-hook'
sample/rsvg/Makefile.am:2: addprefix /r:, $(assemblies: non-POSIX variable name
sample/rsvg/Makefile.am:2: (probably a GNU make extension)
sample/test/Makefile.am:4: addprefix /r:, $(assemblies: non-POSIX variable name
sample/test/Makefile.am:4: (probably a GNU make extension)
sample/test/Makefile.am:26: addprefix $(srcdir: non-POSIX variable name
sample/test/Makefile.am:26: (probably a GNU make extension)
vte/Makefile.am:27: addprefix $(srcdir: non-POSIX variable name
vte/Makefile.am:27: (probably a GNU make extension)
vte/Makefile.am:31: addprefix $(srcdir: non-POSIX variable name
vte/Makefile.am:31: (probably a GNU make extension)
autoreconf: automake failed with exit status: 1
error: Bad exit status from /var/tmp/rpm-tmp.23328 (%prep)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.23328 (%prep)
(END) 

Version-Release number of selected component (if applicable):

Today's rawhide.
Comment 1 Paul F. Johnson 2007-11-14 08:34:01 EST
Which version of mono are you building with? I'm trying to reproduce this on
x86_64 and it seems fine
Comment 2 Lubomir Kundrak 2007-12-18 17:06:17 EST
In any case, calls to autotools don't belong to %prep, whatever the reason it
failed is.
Comment 3 Lubomir Kundrak 2007-12-18 17:09:51 EST
Paul: In x86_64 Fedora 8 it just hangs after "make prep" in "pkgs/gtk-sharp/devel".

The reason for autotools calls being outside prep is that only things absolutely
necessary to get the sources into any human comprehensible form should go to
prep. Packages are prep-ed by some tools even if they are not build, and not
having anything fragile there lowers the chance that something breaks, such as
it did not. Thanks
Comment 4 Paul F. Johnson 2008-05-11 16:59:08 EDT
This has now been fixed - I'm just trying to find what I need to get rsvg-sharp
to build and then it's into rawhide it goes!
Comment 5 Bug Zapper 2008-05-13 23:53:21 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Paul F. Johnson 2008-10-08 15:25:12 EDT
I'm in the process of removing this package from rawhide and f9.

Note You need to log in before you can comment on or make changes to this bug.