Bug 38224 - RFE:vim filetype for xml schemas
Summary: RFE:vim filetype for xml schemas
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vim   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-28 23:18 UTC by Kuratomi, Toshio
Modified: 2007-03-27 03:43 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-28 23:18:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kuratomi, Toshio 2001-04-28 23:18:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; MSNIA; Windows 98)


vim does not have a filetype for the XML Schema type

Reproducible: Always
Steps to Reproduce:
1. start vim on an XML Schema file -- extenstion .xsd
2.
3.
	

Actual Results:  Does not syntax highlight the file

Expected Results:  vim should have syntax highlighted the file as an xml 
file.

To add this: edit the /usr/share/vim/vim60z/filetype.vim file
Around line 1050 there's a definition for xsl (XML Style Language) 
documents.  Add *.xsd to that so the line looks like this:

au BufNewFile,BufRead *.xsl,*.xsd   setf xml

(I'm sorry I can't submit a patch from here :-(

Comment 1 Bernhard Rosenkraenzer 2001-04-30 16:47:28 UTC
Done in 6.0-0.29



Note You need to log in before you can comment on or make changes to this bug.