Bug 382351 - DAAP appears to no longer work with latest upgrade
DAAP appears to no longer work with latest upgrade
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-14 07:58 EST by Luis Villa
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 0.11.3-3.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-20 12:46:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luis Villa 2007-11-14 07:58:03 EST
Description of problem:
I can no longer play tracks (either ogg or mp3) from my home daap server after
upgrading the client to the latest version (0.11.3-1.fc8.i386). It worked with
the previous version available in f8 (0.11.2-10.fc8.i386)

Version-Release number of selected component (if applicable):
0.11.3-1.fc8.i386

How reproducible:
100%. 

Steps to Reproduce:
1. Open rhythmbox and click on daap server (in this case a server running
rhythmbox 0.11.2-0ubuntu; hasn't been upgraded in weeks.)
2. Pick a song, any song.
3. double click on the song; nothing happens. (Should play.)
4. Try instead clicking on play; "Couldn't start playback Unknown playback
error" pops up.
  
Actual results:
No music.

Expected results:
Music!
Comment 1 Bastien Nocera 2007-11-14 08:09:17 EST
Does it happen for all file types, or just one type?
Does enabling (or disabling) the cross-fading make it work?
Comment 2 Luis Villa 2007-11-14 08:32:58 EST
Seems to happen on all the file types I have available (ogg and mp3), and they
both play fine locally and over streaming radio.

If I turn on cross-fading, the error changes from "Couldn't start playback
Unknown playback error" to "Couldn't start playback (null)" but otherwise still
fails.
Comment 3 Bastien Nocera 2007-11-16 08:27:44 EST
Are you using mt-daap2 as well? (like Owen)

I couldn't reproduce those problems locally, and playing music between an RB
0.11.2 and RB 0.11.3 machines work just fine.

And I can't see very many changes between 0.11.2 and 0.11.3 that would result in
DAAP stopping working. But it might be related to:
http://bugzilla.gnome.org/show_bug.cgi?id=470711
or
http://bugzilla.gnome.org/show_bug.cgi?id=390643

Any help from the mt-daap side? (debugging or whatever)
Note that you can also use GStreamer to get debug information (see
http://www.gnome.org/projects/totem/#bugs), or drag'n'drop the source file to
totem or another application that understands HTTP for playback.
Comment 4 Luis Villa 2007-11-16 08:50:05 EST
Nope, no mt-daap running. (Played with it a couple times but could never get it
to  work with ogg.)

If I drag and drop from RB to totem, it says 'An error occurred location not
found'. Not sure if that is useful or not.

Oh, and on the command line, when following the steps described above, I get:
(rhythmbox:9361): RhythmDB-CRITICAL **: rhythmdb_entry_ref: assertion `entry !=
NULL' failed
Comment 5 Bastien Nocera 2007-11-16 10:01:36 EST
Beh. I can reproduce as well, I was using UPNP without realising :)
Comment 6 Bastien Nocera 2007-11-16 11:58:15 EST
Rhythmbox-Message: rb_shell_player_entry_activated_cb: Entry has playback URI
Unknown (location:
daap://192.168.1.106:3689/databases/1/items/4.mp3?session-id=136937119, mount:
Unknown)

Probably a fallback from the work to support stream URLs.
Comment 7 Bastien Nocera 2007-11-16 12:21:42 EST
Work-around at:
http://koji.fedoraproject.org/koji/taskinfo?taskID=244951

Does it work for you, Luis?

Unconvincing analysis at:
http://bugzilla.gnome.org/show_bug.cgi?id=497430
Comment 8 Luis Villa 2007-11-16 14:16:54 EST
Works like a charm...
Comment 9 Fedora Update System 2007-11-17 00:38:06 EST
rhythmbox-0.11.3-3.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rhythmbox'
Comment 10 Fedora Update System 2007-11-20 12:46:01 EST
rhythmbox-0.11.3-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.