Bug 38248 - No ibcs or abi kernel module for sco binaries
No ibcs or abi kernel module for sco binaries
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-29 02:37 EDT by Gary Mason
Modified: 2007-04-18 12:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-13 17:27:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gary Mason 2001-04-29 02:37:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.3DSL i686)


I work for a company that is moving from sco to linux, we are running the
6.2 version with a 2.2.16-3-smp kernel and have a module called ibcs. This
kernel is running the sco binaries just fine but we tried installing 7.1 on
a test server, IBM 5600 with 2 processors, raid controller, 1 gig of ram,
and one external drive array connected to the raid controller, but can only
boot the smp kernel that comes with 7.1. Any attempt to load the enterprise
kernel results in a kernel panic. I have used both initrd images and no
initrd image at all but still get the panic. The server we want to put this
on has 700 users telneted in and a website posting data as well. The main
problems right now is whether or not the enterprise kernel is compiled with
more than 256 pty's available, and are you going to build an rpm package
for the linux abi module. We have tried to compile the most current abi
module to the 2.4.2 kernel rpm source with no luck.  The current smp kernel
only has 256 pty's causing us to recompile the kernel. We have called
support and paid for nothing, the person who was on your support staff did
not have any info for us.

Reproducible: Always
Steps to Reproduce:
1.download 2.4.2 kernel rpm source
2.compile kernel with linux abi included - as a patch
3.boot the new kernel but the sco binaries will not run
	

Actual Results:  None of the sco binaries worked. Usually a segmentation
fault occurs.

Expected Results:  Programs should have run properly. Processes should have
been started during the boot process.
Comment 1 Michael K. Johnson 2001-04-30 11:34:10 EDT
The enterprise kernel has support for >4gb of memory, and it uses a
significant amount of memory to provide that support.  You do not
want to use it on a 1gb machine.  The number of PTYs built in will
not be different.  Without debug information it is hard to guess
why the enterprise kernel paniced.  But for your case it is not
so important because you do not want to use the enterprise kernel
anyway -- more memory and cpu time overhead for no benefit.

We will increase CONFIG_UNIX98_PTY_COUNT for future builds; thank
you for bringing that need to our attention.

We have marked the ibcs facility as deprecated for several releases.
We'll listen for more customer feedback on this issue.
Comment 2 Gary Mason 2001-05-22 23:15:39 EDT
Will there be any support for the linux-abi?
Comment 3 Michael K. Johnson 2001-05-23 11:35:25 EDT
We have marked the ibcs facility as deprecated for several releases.
We'll listen for more customer feedback on this issue.
Comment 4 Michael K. Johnson 2001-05-23 11:45:41 EDT
Oh, I see what the confusion was...

For the 2.4 kernels, linux-abi replaces the ibcs package, but
it was that functionality that we had marked as deprecated.
So my point about waiting for more customer feedback on this
issue really applies to linux-abi.

Sorry for the confusion.
Comment 5 Sergio Tadini 2001-05-28 17:54:00 EDT
We do use iBCS for some parts of our originally SCO running apps, for the 
modules still not ported or impossible to port for link-libs problems;
We built a stable rh6.2-based mix of emulated/compiled application installed at 
about 120 customers here in Italy...
We'd like to start testing rh7.1 for all of the new installations (mainly for 
the new hardware support of 2.4 kernel), but if it lack in iBCS support... we 
can't use it...
Can't you tell something more about future SCO emulation support?
Comment 6 Arjan van de Ven 2001-05-28 18:07:13 EDT
sergio.tadini@digisoft.it:
The chances of future Red Hat kernels supporting it are VERY small. However,
it might be that we provide a patch for linux-abi by some means, totally
unsupported of course.
Comment 7 Need Real Name 2001-06-10 13:36:54 EDT
"Bob Meyers" <oregonbob2000@yahoo.com> wrote in message
news:zcwU6.73$5d.22958@newshog.newsread.com...
> After reading the bugzilla report again I did see an email address for the
> RedHat guy that stated:
>
> "We have marked the ibcs facility as deprecated for several releases.
> We'll listen for more customer feedback on this issue."
>
> His email address is: johnsonm@redhat.com
>
> I intend to fire off a request for SCO binary capability. I encourage
anyone
> else who is interested to do so.


It has been brought to the attention of myself and others like me that
RedHat has officially decided not to bother continuing including or
supporting IBCS in it's Linux distribution.

I am lending my voice to say that the ability to run SCO binaries is a
*MUST*.

I have many customers currently on various versions of SCO osr5 and until I
come across a linux distribution that is even 1/2 as dependable and
problem-free as even the oldest, neglected, un-patched, version of any SCO
OS has been, I still cannot recommend linux to new customers, even though
now some are starting to ask for it specifically.

There are many legacy apps out there that cannot be recompiled for a new
platform, and cannot be replaced. and some actual current apps that are
mission-critical, currently under development, and available for several
flavors of unix, and even Windows, and *not* linux. The end result is, for
those customers who need to upgrade to *something* in order to gain TCP/IP
for instance, the options are the latest version of OpenServer even if it is
a years-old stagnant product, or some version of linux that has a working
ibcs.

Currently this limits linux to 2.2.x kernels.
I know about linux-abi. I have been tracking it's progress closely and have
had it up & running ever since it first became available right up to and
including the current 2.4.5 kernel. However, while it is working fine for
*most* of my sco binaries that have no linux equivalent (after a little
cosmetic hacking by myself), it is not working for at least one of my most
important apps. There happens to be a linux-native version of that app, but
it means re-purchasing the package (expensive!) and therefore eliminates
linux as an upgrade path. (unless, as mentioned, you only upgrade to a 2.2.x
linux)

There are *tons* of current SCO cutomers out there, and SCO-loving
consultants, who are starting to feel "forced" to look at linux against
their will simply because there appears to be nothing that will be like SCO
was, but at least linux will run their many and varied legacy,
mission-critical, irreplaceable, custom applications. Non of us believes for
a second that linux is a tenth as stable as SCO, and we (the consultants)
and our customers value the dependability of the SCO OS above all else. And
Our opinion of Linux (so far) and our opinion of SCO (the OS, not the
company) was not misplaced! Even though our "evidence" is largely anecdotal,
it is greatin quantity and consistant.

With that in mind, I think any major Linux vendor who wants to sell to
buisinesses, should think long and hard before dispensing with ibcs (or
whatever new work-alike that may supercede it, such as linux-abi)

Open Server 5.0.5 came out long enough ago that many who got it are ready to
upgrade again. The OS is generally stable and reliable enough that an even
larger currently installed base are still running much older versions, and
they are doubly ready to upgrade, purely because their hardware is no longer
up to current usage demands. Relatively few have seen a need to get the
recently released 5.0.6, which seems to have very little in the way of
improvements and updates that cannot be downloaded for free and applied to
their existing 5.0.5 & 5.0.4 systems. That amounts to an *awful* lot of
people basically looking at Linux. *Most* of them will either know already,
or be advised by their consultants that they should not even consider any
distribution that does not include a working ibcs so that they do not have
to junk their prorietary software that in most cases they have been paying
programmers to write and work on for many years. That is a very large
investment that no one wants to throw away. Any distribution that tells them
they should throw it away will leave a *very* bad taste in a *lot* of
mouths.

These are the kind of customers who paid $1500 for a *5 user* SCO license
and then another for a 5 or 16 user filePro license, and then who knows how
many thousands for some special purpose app, and then who knows how many
thousands for subsequent custom programming. They will *pay* for a good
product, and pay for support, even if they never actually use it, but the
same thing that makes this so, also means none of them will tolerate a
half-baked and problematical product. whichever linux distribution looks the
most reliable, best supported, _and runs their sco binaries out of the box_
will get their business. pretty desktops and loads of gnome/kde multimedia
toys, cutting edge kernel and application versions, and fancy automatic
hardware detectors are not only passively unimportant to these customers,
they are to some degree actively repellant.

Brian K. White  --  brian@aljex.com  --  http://www.aljex.com/bkw/
+++++[>+++[>+++++>+++++++<<-]<-]>>+.>.+++++.+++++++.-.[>+<---]>++.
filePro BBx  Linux SCO  Prosper/FACTS AutoCAD  #callahans Satriani


Comment 8 Need Real Name 2001-06-10 17:40:14 EDT
If Linux wants to gain a stronger foothold in the commercial server arena, they 
should definitely include SCO Unix binary capability. SCO must still maintain 
one (if not the) of the largest installed base of commercial application 
servers. The fast moving development of Linux makes it a very attractive 
alternative and migration path for current SCO users. This idea is stifled 
however by the fact the Linux support for SCO binaries is waning.

If you want to see how important it is, tune your news-reader to 
comp.unix.sco.misc, or do a google search for 'ibcs' or ABI in that group.
Comment 9 Alessandro Paltrinieri 2001-06-12 16:55:57 EDT
Our company  (and our customers) is using "IBCS"  to run SCO  binary since 1996 
We dont really understand why to throw away a good thing, without a valid
substitute for it.

We still have many customer, running on SCO and waiting an "upgrade" to linux,
but without
IBCS we still have to keep SCO UNIX.

I Hope Linus and his guy want (or RedHat) come back or give us (the users)
something good in change.
Comment 10 Need Real Name 2001-07-09 17:30:08 EDT
We have been been in the process of testing our software on some Redhat Linux 
systems for close to a year next to systems running on SCO boxes. The systems 
are up 24/7 and are used to process millions of records daily. We have been 
using ibcs and found we had to make only minor changes mainly because of 
incompatabilies of the Bash shell. It has been a long road to prove the 
stability of the Redhat boxes and were surprised to find they could process 
data faster than the SCO systems with the same hardware configuration. We have 
also replaced some of our W2K fileservers using Samba which has worked out very 
well. We have several machines out in the field, mainly Fortune 500 companies, 
running our software on SCO boxes also.

Because of Redhat's decision to drop ibcs I am faced with a big problem not to 
mention  having to deal with all the I told you so's that Linix was not for 
business. I picked Redhat because I believed they would go after the business 
market and hopefully would make the right decisions to do so. Now is Redhat's 
chance to do just that. Putting ibcs back in makes business sense leaving it 
out makes no sense.

Comment 11 Michael K. Johnson 2001-07-09 18:53:50 EDT
I'd like to thank everyone who responded.  We are experimenting more
seriously with linux-abi and are seriously considering reversing our
position on this.  linux-abi probably won't be tier-1 supported, but
will probably be supported just like ibcs was before, which seems to
have been satisfactory in the past.
Comment 12 Gary Mason 2001-07-10 20:02:17 EDT
There is a current linux-abi module available now. We have tried it out and it
works perfect on out 2.4.6 kernel. To get the latest linux-abi-2.4.6, go to this
link:

ftp.openlinux.org:/pub/people/hch/linux-abi/linux-abi-2.4.6.0.diff.

All of our sco binaries are working perfectly under this version.

Comment 13 Arjan van de Ven 2001-07-11 04:56:55 EDT
As you can see in rawhide (a snapshot of our development), a (currently slightly
older, but that will get updated soon) version of this patch is in our current
working kernel.
Comment 14 Tony Scholes 2001-09-13 17:27:47 EDT
Hi

SCO Binary support is essential for the next 3-> 5 years, there are many 
binaries that can *never* be ported to Linux (no source is available) and they 
must run on systems that replace existing SCO systems

IMHO it was a daft decision to not include SCO Openserver binary support out of 
the box, in 15 years I have rarely seen a more stupid thing happen.

Comment 15 Arjan van de Ven 2001-10-20 13:29:53 EDT
Kernel release 2.4.9-6 (released a few days ago) has the linux-abi patches
included.

Note You need to log in before you can comment on or make changes to this bug.