Bug 38249 - JDK1.3 and JDK1.3..0_2 will not run
Summary: JDK1.3 and JDK1.3..0_2 will not run
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-29 06:38 UTC by Chris Croswhite
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-30 17:45:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Croswhite 2001-04-29 06:38:50 UTC
Sun's and Blackdown's java from jdk1.3 and jdk1.3.0_2 (Sun only) hang the 
terminal.  First, I had to place the libjvm.so (from 
jdk_inst_dir/jre/lib/i386/client/) into /usr/lib.  Then I ran java -
version from jdk_inst_dir/bin and the term just sits there.  A ps shows no 
activity to the associated java processes.  JDK1.2 seems to run fine.

I think this might be a good time to put in a plug from having Red Hat 
include a good reference java rather than that quassi knock-off called 
kaffe.  Come on guys!  You can package the jre in the distro not to 
mention Blackdown's implementation.

Comment 1 Rob Lembree 2001-04-30 01:31:18 UTC
I can confirm that this is a problem.  I'm going to have to downgrade because
of this problem.

regards,
rob lembree (lembree@metrolink.com)

Comment 2 Bill Nottingham 2001-04-30 02:15:35 UTC
Um, no we can't ship any JDK/JRE environments. The licenses prohibit
them, and they aren't open source anyway.

Did you try setting LD_ASSUME_KERNEL as specified in the release notes?

Comment 3 Rob Lembree 2001-04-30 04:30:47 UTC
Here are the results.

% export LD_ASSUME_KERNEL=1
% /Work/jdk1.3/bin/java
/bin/sh: error while loading shared libraries: libdl.so.2: cannot load shared
object file: No such file or directory

Comment 4 Jakub Jelinek 2001-04-30 07:38:29 UTC
You should use
export LD_ASSUME_KERNEL=2.2.5
It is written in RELEASE-NOTES btw.

Comment 5 Rob Lembree 2001-04-30 17:45:26 UTC
 export LD_ASSUME_KERNEL=2.2.5 does indeed work around this problem.
What side-effects might this have on other things?   Are the release notes
available online?



Comment 6 Jakub Jelinek 2001-04-30 18:03:49 UTC
ftp://ftp.redhat.com/redhat/linux/7.1/en/os/i386/RELEASE-NOTES
The effect of LD_ASSUME_KERNEL=2.2.5 is:
a) libc (libm, libpthread) no longer assume they run on kernel 2.4.1 and above
   (the assumption means some optimizations)
b) libpthread cannot use %gs register based threads, they use the stack pointer
   based fixed stack size threads
So basically it is mainly a performance issue, or if some threaded application
needs to use either smaller or larger stacks than 2MB (smaller so that it
can fit more threads into virtual memory).


Note You need to log in before you can comment on or make changes to this bug.