Bug 382521 - qt-designer crashes with menu drop shadow enabled
qt-designer crashes with menu drop shadow enabled
Status: CLOSED DUPLICATE of bug 390261
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks: c->xlib.lock
  Show dependency treegraph
 
Reported: 2007-11-14 09:31 EST by Darrell Walisser
Modified: 2013-01-09 23:30 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-18 13:20:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 254144 None None None Never

  None (edit)
Description Darrell Walisser 2007-11-14 09:31:54 EST
Description of problem:
Clicking in menus or right-clicking on some things causes crash, only 
when "Menu drop shadow" is enabled in Control Center -> Appearance and 
Themes -> Style -> Effects

Version-Release number of selected component (if applicable):
qt 1:3.3.8-9.fc8.i386
qt-designer 1:3.3.8-9.fc8.i386

How reproducible: Always

Steps to Reproduce:
1. Enable Menu Drop Shadow
2. Open qt designer
3. Click on a menu, such as the "File" menu
  
Actual results:

X Error: BadMatch (invalid parameter attributes) 8
  Major opcode:  62
  Minor opcode:  0
  Resource id:  0x1600b5b
designer: xcb_xlib.c:41: xcb_xlib_lock: Assertion `!c->xlib.lock' failed.

Program received signal SIGABRT, Aborted.
[Switching to Thread -1208903456 (LWP 5500)]
0x00110402 in __kernel_vsyscall ()
(gdb) where
#0  0x00110402 in __kernel_vsyscall ()
#1  0x008d4690 in raise () from /lib/libc.so.6
#2  0x008d5f91 in abort () from /lib/libc.so.6
#3  0x008cd93e in __assert_fail () from /lib/libc.so.6
#4  0x00b84714 in xcb_xlib_lock () from /usr/lib/libxcb-xlib.so.0
#5  0x00ac6168 in ?? () from /usr/lib/libX11.so.6
#6  0x00aa0769 in XFlush () from /usr/lib/libX11.so.6
#7  0x021d1424 in QApplication::flushX () 
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#8  0x021d1447 in QApplication::flush () 
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#9  0x081aace1 in ?? ()
#10 0x025b9102 in qWarning () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#11 0x021d1cef in ?? () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#12 0x00abf71e in _XError () from /usr/lib/libX11.so.6
#13 0x00ac6aaa in ?? () from /usr/lib/libX11.so.6
#14 0x00ac718c in _XReply () from /usr/lib/libX11.so.6
#15 0x00aa5ffc in _XGetWindowAttributes () from /usr/lib/libX11.so.6
#16 0x00aa6152 in XGetWindowAttributes () from /usr/lib/libX11.so.6
#17 0x022006ad in QPixmap::grabWindow () 
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#18 0x00235d50 in ?? () from /usr/lib/libkdefx.so.4
#19 0x022b4f3c in QObject::activate_filters () 
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#20 0x022b4fbb in QObject::event () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#21 0x022f1e6c in QWidget::event () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#22 0x0224c38b in QApplication::internalNotify () 
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#23 0x0224d967 in QApplication::notify () 
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#24 0x022f2e67 in QWidget::show () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#25 0x023d4c20 in QPopupMenu::show () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#26 0x023d75e0 in QPopupMenu::popup () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#27 0x023d7d14 in QPopupMenu::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#28 0x08098bb6 in ?? ()
#29 0x082924d6 in ?? ()
#30 0x080a0996 in ?? ()
#31 0x0224c34b in QApplication::internalNotify () 
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#32 0x0224de95 in QApplication::notify () 
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#33 0x021e38c5 in QETWidget::translateMouseEvent () 
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#34 0x021e2036 in QApplication::x11ProcessEvent () 
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#35 0x021f3cbb in QEventLoop::processEvents () 
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#36 0x02265c60 in QEventLoop::enterLoop () 
from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#37 0x02265b16 in QEventLoop::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#38 0x0224bfcf in QApplication::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#39 0x080850b4 in QWidget::setUpdatesEnabled ()
#40 0x008c1390 in __libc_start_main () from /lib/libc.so.6
#41 0x08084331 in QWidget::setUpdatesEnabled ()
(gdb)  

Expected results:
Display of menu w/drop shadow

Additional info:

Could be related to Xinerama.

http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6532373
Comment 1 Jesse Keating 2008-04-18 11:19:31 EDT
I assume this is still happening in rawhide, since I haven't seen any updates?
Comment 2 Ngo Than 2008-04-18 13:20:34 EDT
it's a bug in libxcb

*** This bug has been marked as a duplicate of 390261 ***

Note You need to log in before you can comment on or make changes to this bug.