Bug 382771 - There is no libmpfr.a
There is no libmpfr.a
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mpfr (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-14 11:18 EST by H.J. Lu
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 05:50:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description H.J. Lu 2007-11-14 11:18:32 EST
mpfr-devel-2.3.0-1.fc8 doesn't include libmpfr.a. gmp-devel-4.1.4-12.3 in
F7 does include libmpfr.a.
Comment 1 Ivana Varekova 2007-11-15 05:50:51 EST
There is trend to exclude static libraries - 
http://fedoraproject.org/wiki/Packaging/Guidelines#head-2302ec1e1f44202c9cc4bcce24cb711266557ad7
so it is ok. 
But if the static libraries are necessary for some package they could be added
again but there have to be reason why this package can't use dynamic library. So
if there is no such package then this is not a bug. 
If there is such a reason to add libmpfr.a please reopen this bug and write it
here. Thanks.

Note You need to log in before you can comment on or make changes to this bug.