Bug 382781 - wifi regression in rt2500pci module with 2.6.23.1-49.fc8
wifi regression in rt2500pci module with 2.6.23.1-49.fc8
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-14 11:33 EST by Eric Tanguy
Modified: 2008-01-14 09:10 EST (History)
5 users (show)

See Also:
Fixed In Version: 2.6.23.13-104.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-10 16:33:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
register dump script (460 bytes, application/x-shellscript)
2008-01-03 17:06 EST, Ivo van Doorn
no flags Details

  None (edit)
Description Eric Tanguy 2007-11-14 11:33:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.1.8) Gecko/20071030 Fedora/2.0.0.8-2.fc8 Firefox/2.0.0.8

Description of problem:
Booting the 2.6.23.1-49.fc8 kernel with wlan0 enable at boot leads to erratic transfer rate. Booting 2.6.23.1-42.fc8 in the same condition leads to a stable transfer rate.

Version-Release number of selected component (if applicable):
kernel-2.6.23.1-49.fc8

How reproducible:
Always


Steps to Reproduce:
1.Boot kernel 2.6.23.1-49.fc8
2.test transfer rate with another machine in the same lan
3.see an erratic instant transfer rate 

Actual Results:


Expected Results:


Additional info:
Comment 1 John W. Linville 2007-11-14 17:45:44 EST
Might I ask you to try a few earlier .fc8 kernels, to see if any of them are 
more stable w.r.t. wireless?

   http://koji.fedoraproject.org/koji/packageinfo?packageID=8

Which kernels work better?
Comment 2 Eric Tanguy 2007-11-15 00:28:49 EST
Now i work with kernel 2.6.23.1-42.fc8 and the connection is very stable so the
regression seems to be between 2.6.23.1-42.fc8 and 2.6.23.1-49.fc8. Which kernel
do you want i try ?
Comment 3 John W. Linville 2007-11-15 10:55:12 EST
It is a longshot, but please try these kernels:

   http://koji.fedoraproject.org/koji/taskinfo?taskID=241980

Do you get stable throughput with these kernels?
Comment 4 Eric Tanguy 2007-11-15 12:25:59 EST
I tried kernel-2.6.23.1-53.wl.1.fc8.i686 and the problem is still here. Do not
hesitate to ask me more test.
Comment 5 John W. Linville 2007-11-21 15:48:56 EST
These have more extensive wireless updates:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=25030

Could you give them a try?
Comment 6 Eric Tanguy 2007-11-22 03:17:54 EST
I tried kernel-2.6.23.8-62.fc8.i686 but the problem is still here. So i
investigate a little more and it seems that the directive RATE=Auto in
/etc/sysconfig/network-scripts/ifcfg-wlan0 does not work anymore. I need in
place to have RATE=54Mb to obtain a stable connexion. If i let  RATE=Auto, i
always have  Bit Rate=1 Mb/s with iwconfig.
Hope this will help you ...
Comment 7 John W. Linville 2007-11-26 15:01:24 EST
Ah, OK...we are seeing a similar problem with upstream kernels.  I'll have to 
get back to you once we discover the root of the problem...
Comment 8 Eric Tanguy 2007-12-15 10:55:14 EST
Some news about this ?
Comment 9 John W. Linville 2007-12-17 10:33:23 EST
Nothing to report...
Comment 10 Eric Tanguy 2007-12-21 13:12:35 EST
The problem is still here in 2.6.23.9-85.fc8.
Comment 11 John W. Linville 2008-01-02 14:53:05 EST
Ivo, is it possible that rt2x00 is not providing the proper information back 
to the rate control algorithms?
Comment 12 Ivo van Doorn 2008-01-02 17:13:26 EST
John, are the following 3 patches inside the latest FC kernel?
 
rt2x00: Only update rssi average approximation on receiving beacon frames.
http://git.kernel.org/?p=linux/kernel/git/ivd/rt2x00.git;a=commit;h=8dd1ca488b9740cc33d45fb1c28b0a3f2768b891

rt2x00: Correctly set ACK bit in tx descriptors
http://git.kernel.org/?p=linux/kernel/git/ivd/rt2x00.git;a=commit;h=8a99312dec3e5e4cbc2ac01e71ce953aa97cf343

[PATCH] rt2x00: Fix residual check in PLCP calculations.
http://git.kernel.org/?p=linux/kernel/git/ivd/rt2x00.git;a=commit;h=db15178755f823d1fa8c242210cf04c26fca1483
Comment 13 John W. Linville 2008-01-03 10:36:01 EST
Not sure about -85.fc8, but all of those are available in -99.fc8:

  http://koji.fedoraproject.org/koji/buildinfo?buildID=28665

Eric, can you try the -99.fc8 kernels and report the results back here?

Thanks!
Comment 14 Eric Tanguy 2008-01-03 14:38:14 EST
The same. If i put RATE=Auto i obtain Bit Rate=1 Mb/s and the connection is very
slow and i put RATE=54Mb all work fine.
Comment 15 Eric Tanguy 2008-01-03 17:00:07 EST
Here it seems to be the same problem with the same solution : 
http://www.redhat.com/archives/fedora-list/2008-January/msg00359.html
Comment 16 Ivo van Doorn 2008-01-03 17:06:11 EST
Created attachment 290788 [details]
register dump script

Not sure if it is possible, but is DEBUGFS available in Fedora kernels?
If so, please mount debugfs and run the following script inside the rt2500pci
entry within the mac80211 debugfs entry.

Please do this with both the working kernel and the non working kernel and
store the output in 2 different files.
Comment 17 Ivan Virgili 2008-01-03 17:14:27 EST
I can confirm I am having the same problem.
Very slow connection with Rate=Auto, normal/fast connection if I set Rate=54M
I am using kernel -99.fc8
Comment 18 Eric Tanguy 2008-01-04 02:36:47 EST
(In reply to comment #16)
> Created an attachment (id=290788) [edit]
> register dump script
> 
> Not sure if it is possible, but is DEBUGFS available in Fedora kernels?

I don't know maybe someone else (John ?) could answer.

> If so, please mount debugfs and run the following script inside the rt2500pci
> entry within the mac80211 debugfs entry.

I don't understand what you mean. Please be more detailed because i'm a newbie
in kernel.

> 
> Please do this with both the working kernel and the non working kernel and
> store the output in 2 different files.
You mean for the working kernel the one before 2.6.23.1-49.fc8 ?

Comment 19 Ivo van Doorn 2008-01-04 14:22:42 EST
(In reply to comment #18)
> > If so, please mount debugfs and run the following script inside the 
rt2500pci
> > entry within the mac80211 debugfs entry.
> 
> I don't understand what you mean. Please be more detailed because i'm a 
newbie
> in kernel.

As root do:

mount -t debugfs /sys/kernel/debug

Then:

Then check the contents of /sys/kernel/debug, there should be a ssubdirectory 
for your wireless interface if you go in there you find a folder 
named "rt2500pci" (it might be several folders deeper).
When you are inside the rt2500pci/register folder, run the attached script and 
redirect the output to a new file. Do this for both the working and the 
non-working kernel and you will have 2 files, please attach those 2 files to 
this report.

> > 
> > Please do this with both the working kernel and the non working kernel and
> > store the output in 2 different files.
> You mean for the working kernel the one before 2.6.23.1-49.fc8 ?
> 
> 

From your report I understood that the last working kernel was: 
2.6.23.1-42.fc8
And the first broken kernel was: 2.6.23.1-49.fc8

So please test with those 2 kernels.

Of course using a even more recent kernel would also be very nice just in case 
the problem has already been resolved. :)
Comment 20 Eric Tanguy 2008-01-04 16:38:42 EST
# mount -t debugfs /sys/kernel/debug
Usage: mount -V                 : print version
       mount -h                 : print this help
       mount                    : list mounted filesystems
       mount -l                 : idem, including volume labels
...
So either debugfs is not implemented or the command line is not good.
Comment 21 Ivo van Doorn 2008-01-04 16:58:18 EST
Sorry about that:

mount -t debugfs debugfs /sys/kernel/debug/
Comment 22 Eric Tanguy 2008-01-04 17:10:08 EST
Ok now i can mount but in /sys/kernel/debug/ i have only ieee80211, kprobes and
usbmon directories. Under ieieee80211 i have a dir : phy0 and nothing in it.
Comment 23 Eric Tanguy 2008-01-06 11:10:39 EST
I tried 2.6.23.12-101.fc8 and the problem is still present.
Comment 24 Ivan Virgili 2008-01-08 15:38:55 EST
I installed Kernel 2.6.23.12-101.fc8 and the problem is still there.
Morover I cannot even modify the speed by using iwconfig. It is stuck at 1 Mb/s.
If I start my computer using Kernel 2.6.23.12-99.fc8 then I can still modify the
speed manually with "iwconfig wlan1 rate 54M"
If I modify the wlan configuration file/files and set the rate to 54M, this does
have not effect at all. The only way to modify the speed is by using iwconfig
and by using Kernel -99.f8
Comment 25 Eric Tanguy 2008-01-10 14:29:10 EST
The bug seems solved in kernel-2.6.23.13-104.fc8. More test are welcome.
Comment 26 Ivan Virgili 2008-01-10 15:48:16 EST
Confirmed. I installed kernel-2.6.23.13-104.fc8 and the speed is now adjusted
automatically depending on the quality of the signal.
Comment 27 Ivo van Doorn 2008-01-10 15:59:27 EST
Excellent news. :)
Comment 28 Mats Ljunggren 2008-01-12 04:15:14 EST
Since I have the same problem described in this bug report I tested kernel-
2.6.23.13-104.fc8 too. Unfortunately, my wlan card (using rt61pci) doesn't 
associate at all any longer with my wlan router. iwlist wlan0 scan doesn’t show 
any access points. I tested kernel-2.6.23.13-105.fc8 too with the same result. 
Should I submit a new bug report on this? I don’t know if I’m supposed to do 
that on kernels that haven’t been released yet.
Comment 29 John W. Linville 2008-01-14 09:10:02 EST
Open a new bug.

Note You need to log in before you can comment on or make changes to this bug.