Bug 38288 - AC97 sound does not work in SMP kernel
Summary: AC97 sound does not work in SMP kernel
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-29 10:26 UTC by greg hosler
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-29 10:40:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description greg hosler 2001-04-29 10:26:43 UTC
more specifically, when the AC97 sound chip (via82cxxx_audio.c) has the IRQ
re-assigned
(as happens probably always under SMP kernel, because of IO-APIC remapping
of the
IRQ's), the AC97 is not properly initialized, such that it doesn't
interrupt properly

The older AC97 driver used legacy support, and did not have to deal w/ the
remapped
irq. The newer driver attempts to run the via686 natively, and has code to
remap the
IRQ (see code around IRQ fixup, 0x3C==%d in via82cxxx_audio.c) but this
code does not
work properly. The hardware never interrupts.

motherboard used: MSI-6321 (a.k.a. a MSI 694D)

-Greg

Comment 1 Arjan van de Ven 2001-04-29 10:40:29 UTC
I have this motherboard as workstation, I'll give it a try on monday.

Comment 2 greg hosler 2001-05-03 11:46:26 UTC
The motherboard I was having this problem on is a MSI-6321 (a.k.a. 694d Pro)

The problem turned out to be a BIOD IO-APIC mapping issue which was solved by
updating
the bios to the current bios patch level.



Note You need to log in before you can comment on or make changes to this bug.