Bug 382891 - pcm_params.c:2351: sndrv_pcm_hw_params: Assertion `err >= 0' failed.
pcm_params.c:2351: sndrv_pcm_hw_params: Assertion `err >= 0' failed.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
https://bugtrack.alsa-project.org/als...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-14 12:15 EST by Naveed Hasan
Modified: 2008-06-12 00:35 EDT (History)
4 users (show)

See Also:
Fixed In Version: 9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-12 00:35:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Naveed Hasan 2007-11-14 12:15:00 EST
Various applications using sound always fail in Fedora 8. Appears to be an
upstream ALSA bug.

https://bugtrack.alsa-project.org/alsa-bug/view.php?id=2601
http://pulseaudio.org/ticket/23

I encountered it when trying to start ustunts (from the
ultimatestunts-0.7.3-4.fc8.x86_64 package.)
Comment 1 Martin Stransky 2007-12-07 06:16:56 EST
aha, okay. moved to pulseaudio.
Comment 2 Naveed Hasan 2007-12-14 03:30:41 EST
The comments at the two links I originally posted seemed to imply the bug is
somewhere in alsa-lib.

In any case, that these applications fail to start / crash due to the new alsa /
pulseaudio setup in Fedora 8 is very unfortunate.
Comment 3 JM 2008-01-21 13:21:57 EST
I have the same problem with xemacs (when I use sound in the xemacs config),
xemacs fails then with:

xemacs: pcm_params.c:2351: sndrv_pcm_hw_params: Assertion `err >= 0' failed.

My workaround for the moment is to remove 'alsa-plugins-pulseaudio', I found
this workaround here
http://support.gizmoproject.com/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid=330
Comment 4 Mark Wielaard 2008-01-23 15:07:43 EST
This also causes ekiga to crash and burn unless you set "Preferences -> Sound
Events -> Alternative Output Device" to anything NOT the "Default".
Comment 5 Lennart Poettering 2008-03-28 16:14:04 EDT
This is most likely fixed by the newest alsa-plugins-pulseaudio. Could you
please try?
Comment 6 Naveed Hasan 2008-03-28 21:15:18 EDT
No such luck - it's still broken with the same error message. Does
alsa-plugins-pulseaudio-1.0.15-3.fc8.1 include this patch
https://bugtrack.alsa-project.org/alsa-bug/file_download.php?file_id=2513&type=bug
 as described on https://bugtrack.alsa-project.org/alsa-bug/view.php?id=2601 or
would change need to go into an updated alsa-lib?
Comment 7 Naveed Hasan 2008-06-12 00:35:56 EDT
It looks like this bug has been fixed in Fedora 9. I currently have
alsa-lib-1.0.16-3.fc9 and alsa-lib-1.0.16-3.fc9 installed and ustunts now starts
fine.

Note You need to log in before you can comment on or make changes to this bug.