Bug 382971 - broken sliders in alsa volume control
broken sliders in alsa volume control
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-14 13:15 EST by Dave Jones
Modified: 2015-01-04 17:30 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-09 18:46:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
amixer output (11.21 KB, text/plain)
2007-12-03 01:18 EST, Dave Jones
no flags Details

  None (edit)
Description Dave Jones 2007-11-14 13:15:50 EST
the left and right sliders of each control in the volume applet are 'linked' by
a chain below the sliders.  When I move the sliders by clicking and dragging,
the link gets broken, and only the slider that was clicked moves.
If I scroll with the mousewheel it does the right thing.

Pulse seems determined to break the link between the two.  Either this should be
fixed, or the link icon should be removed.
Comment 1 Lennart Poettering 2007-11-29 19:47:29 EST
Hmm, cold you please provide me with the output of "amixer -c 0 contents" on
your machine?

ALSA exports a lot of information about the properties of each volume control
slider, this might be set incorrectly on your driver. Among other stuff it flags
controls where L and R cannot be manipulated independently.
Comment 2 Dave Jones 2007-12-03 01:18:00 EST
Created attachment 275421 [details]
amixer output

sure, attached.

something to note also, is that this doesn't always happen.
I just tried to duplicate it to be sure it still happens, and it took me a few
tries of loading the volume applet and sliding up and down before it broke.
Comment 3 Lennart Poettering 2008-09-09 18:46:00 EDT
This shouldn't happen anymore since we now extend the hw volume range in software, which means we can always provide what clients ask for, and allow per-channel volumes even if the sound card only has an all-channel volume control. Closing now. If this persists on current rawhide (0.9.12) feel free to reopen.

Note You need to log in before you can comment on or make changes to this bug.