Bug 383111 - wdm is not ConsoleKit-aware, so sound only works as root
wdm is not ConsoleKit-aware, so sound only works as root
Status: CLOSED DUPLICATE of bug 228079
Product: Fedora
Classification: Fedora
Component: wdm (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Patrice Dumas
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-14 14:19 EST by Joshua Jensen
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-16 13:08:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Jensen 2007-11-14 14:19:11 EST
Description of problem:

My gnome desktop isn't giving me any sound.  the volume controls don't even
work.  Upon investigation, I find that root has sound, non-root users don't:

$ aplay /usr/share/sounds/gtk-events/clicked.wavPlaying WAVE
'/usr/share/sounds/gtk-events/clicked.wav' : Signed 16 bit Little Endian, Rate
44100 Hz, Mono
*** PULSEAUDIO: Unable to create stream.
aplay: set_params:962: Unable to install hw params:
ACCESS:  RW_INTERLEAVED
FORMAT:  S16_LE
etc

$ aplay -l /usr/share/sounds/gtk-events/clicked.wav
aplay: device_list:205: no soundcards found...

$ sudo aplay -l /usr/share/sounds/gtk-events/clicked.wav
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC260 Analog [ALC260 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

#So root has something... non-root doesn't....

$ sudo aplay /usr/share/sounds/gtk-events/clicked.wav
W: core-util.c: Failed to open configuration file
'/users/jjensen/.pulse/client.conf': Permission denied
E: authkey.c: Failed to open cookie file '/users/jjensen/.pulse-cookie':
Permission denied
E: authkey.c: Failed to load authorization key '/users/jjensen/.pulse-cookie':
Permission denied
*** PULSEAUDIO: Unable to connect: Connection refused
aplay: main:546: audio open error: Connection refused

Now I comment out the line "/etc/alsa/pulse-default.conf" in
/etc/alsa/alsa.conf, to remove pulse from the equation:

$ sudo aplay /usr/share/sounds/gtk-events/clicked.wav
(I hear it!)


So I need your guidance here... I'm not sure if this is a pulse audio problem,
or if pulse is just confusing the issue and it is a "non-root users can't get to
alsa" problem.  Please help!


Version-Release number of selected component (if applicable):

f8 x86_64, with all updates as of Nov 14th 2007.
Comment 1 Joshua Jensen 2007-11-14 18:24:17 EST
I have found a common theme here... when I use xdm or wdm, I get no sound.  When
I use gdm the sound works.

SURELY gdm isn't required to get sound working in Gnome!?
Comment 2 Will Woods 2007-11-15 14:26:02 EST
ConsoleKit is required to set the permissions on the sound devices properly. If
your login manager doesn't use ConsoleKit then it won't grant you the right
permissions on your sound devices.
Comment 3 Joshua Jensen 2007-11-15 16:05:59 EST
Wow... so this is a big change in what DMs are/were expected to do.  Is there no
way to make ConsoleKit aware of a *local* login via pam, or via the ConsoleKit
daemon?

Seems like DMs shouldn't have to do something special to make sound work. 
Comment 4 Will Woods 2007-11-15 16:21:42 EST
On the contrary, *something* has to change permissions to ensure that the
logged-in user (and only that person) has access to things like sound devices.
In the past it was pam_console, but this is being obsoleted by ConsoleKit /
PolicyKit. 

See http://fedoraproject.org/wiki/Releases/FeatureRemovePAMConsole or
http://fedoraproject.org/wiki/Desktop/FastUserSwitching for some details.

GDM and KDM both support ConsoleKit. It's a bug in wdm/xdm that they don't.
There are actually patches that add ConsoleKit support to xdm floating around;
not sure about wdm.
Comment 5 Joshua Jensen 2007-11-15 16:41:32 EST
I'll buy that... pam_console needs to go away, and HAL/ConsoleKit is the way to
handle permissions.  Should we change this to a bug against wdm then?
Comment 6 Will Woods 2007-11-15 17:04:54 EST
I guess you're using wdm then? Moving this to a wdm bug.
Comment 7 Patrice Dumas 2007-11-16 13:08:46 EST

*** This bug has been marked as a duplicate of 228079 ***

Note You need to log in before you can comment on or make changes to this bug.