Bug 383201 - 32-bit pam_winbind.so incompatible with 64-bit winbindd
32-bit pam_winbind.so incompatible with 64-bit winbindd
Status: CLOSED DUPLICATE of bug 356851
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: samba (Show other bugs)
5.1
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Samba Maint Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-14 14:37 EST by Marcos S. Trazzini
Modified: 2008-01-25 10:31 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-14 16:20:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 253036 None None None Never

  None (edit)
Description Marcos S. Trazzini 2007-11-14 14:37:17 EST
Description of problem:

The 32-bit version of pam_winbind.so, needed for 32-bit pam-compatible
applications does not work on a system running a 64-bit winbind daemon. So, I'm
having problems with some 32bit only applications to authenticate.

Exactly the same behavior was previously reported (and fixed) on FC7:
https://bugzilla.redhat.com/show_bug.cgi?id=253036

Version-Release number of selected component (if applicable):

samba-3.0.25b-0.el5.4.x86_64
samba-common-3.0.25b-0.el5.4.x86_64
samba-common-3.0.25b-0.el5.4.i386

How reproducible:

Setup a 32-bit, pam-compatible application to use pam_winbind.so on an x86_64
system. It will never successfully authenticate.

Steps to Reproduce:
1. Install 64-bit samba and samba-common.
2. Setup winbindd to work in a 64-bit environment. Make sure wbinfo works.
3. Install a 32-bit pam-aware app.
4. Install 32-bit samba-common for 32-bit pam_winbind.
5. Configure pam for this 32-bit app to use pam_winbind.
  
Actual results:

The authentication fails.

Expected results:

We expect that the authentication works.

Additional info:
Comment 1 Simo Sorce 2007-11-14 16:20:16 EST

*** This bug has been marked as a duplicate of 356851 ***

Note You need to log in before you can comment on or make changes to this bug.