Bug 38328 - Mozilla is pedantic about bad JavaScript.
Mozilla is pedantic about bad JavaScript.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: mozilla (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-29 14:56 EDT by David Woodhouse
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-29 14:56:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2001-04-29 14:56:12 EDT
Mozilla refuses to work with a number of technically invalid JavaScript
constructs, which are in common use in the wild because they were
implemented in Netscape 4.x or IE.

For Mozilla, this makes perfect sense. 'Encouraging' standards-compliance
is a good thing.

However, if we want to ship Mozilla as a replacement for Netscape, perhaps
we should be slightly more permissive.

I don't know how feasible it is to support the non-standard extensions such
as the ones used by https://www.nwolb.co.uk/ but I think it's going to be
quite a long time before server admins catch up and make it work.

If it's feasible to make these sites work for users of Red Hat's Mozilla,
by implementing backward-compatibility with Netscape 4.x, then it will make
the migration from Netscape far easier.
Comment 1 Christopher Blizzard 2001-06-09 17:57:54 EDT
This bug is too vague.  The javascript error in this case was:

netscape.softupdate has no properties.

I'm not sure if that's a bug or not. :)  It should end up in mozilla's bug
repository if it actually is a bug, though.
Comment 2 David Woodhouse 2001-06-09 18:32:46 EDT
You could perhaps make a case for forgiving the lack of netscape.softupdate.

If you're so inclined, ignore the softupdate bit and go directly to the login page.

cf. Mozilla bug #65944.

Note You need to log in before you can comment on or make changes to this bug.