Bug 38329 - LVM driver or module will not load.
LVM driver or module will not load.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-29 15:09 EDT by Need Real Name
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-10 14:04:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-04-29 15:09:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)


I started with a fresh install of RH 7.1. I tried to use kernel load and
module. I try to use vgscan it comes back with error "lvmiopversion -- LVM
driver/module not loaded?" I tried using the module I get this error "Using
/lib/modules/2.4.2-2/kernel/drivers/md/lvm-mod.o
/lib/modules/2.4.2-2/kernel/drivers/md/lvm-mod.o: unresolved symbol
blk_queue_make_request_Rfdf86043
/lib/modules/2.4.2-2/kernel/drivers/md/lvm-mod.o: unresolved symbol
generic_make_request_R4e241fef" I tried to use LVM updated patches. I even
tried the lates beta patch "lvm-0.9.1_beta7-2.4.2-2.patch" I still recieve
the same errors. I also insured the source was clean using make mrpoper. I
performed a make modules it compiled the lvm-mod.o without any logged
errors. 

Reproducible: Always
Steps to Reproduce:
1.Install kernel source
2.Select lvm as module or kernel 
3.Compile kernel and/or install modules
4.Load lvm modules
	

Actual Results:  Recieve unresolved symbol erros

Expected Results:  lvm module should load allowing to use vgscan.
Comment 1 Arjan van de Ven 2001-04-29 15:25:30 EDT
2 things:

1) LVM is not supported; it is quite buggy in the mainstream kernels and "newer"
   betaversions aren't nearly compatible enough

2) If you changed the .config to include LVM, you must also create a new
   vmlinuz file by using "make bzImage", as even turning LVM on as a module
   requires several changes in core-kernel code.
Comment 2 Need Real Name 2001-05-01 22:15:14 EDT
I did follow those steps, and ran make bzlilo after the making the changes to
the core kernel. If LVM is not supported why is it in the kernel selection?
That was the reason why I upgrade to 7.1. To use the 2.4x kernel. I did have
LVM working under wolverine with the 2.4.1 kernel. I went to beta version as
a last resort, since I couldn't get the the stable version to work with RH 7.1
hoping for some fixes.
Comment 3 Need Real Name 2001-05-01 22:23:32 EDT
Also another note I went to RH 7.1 because I was running into memory issues and
was recommended by bugzilla to go to the next kernel version of RH. What a
better way to go, then to go the next RELEASED VERSION.  The step process also
include first with an upgrade. However that didn't work. So I wiped my system,
and started with a fresh install. There was no notes in RH Documentation stating
that LVM is not supported. Matter of fact LVM is in the
/usr/src/linux/Documentation. So could we try this again, and not give a
Microsoft Answer.
Comment 4 Arjan van de Ven 2001-05-02 04:29:48 EDT
Yes the 2.4 kernel has code that pretends to be LVM. And no it does not work
reliably. That is why we (Red Hat) have it disabled it for the kernels we ship.

If you want to build it into your own kernel, you can. The LVM in the
kernelsources we ship will compile. Install the kernel-sources rpm and do the
following steps:

cd /usr/src/linux-2.4.2
make mrproper
make menuconfig
-> pick "load" and load the config file you want from the configs/ directory
-> change the LVM setting and any others you want
-> hit "save"
make dep
make bzImage
make modules
make modules_install
and then install the arch/i386/boot/bzImage wherever you want it, in the way
you usually do that.

However, don't yell at me if it crashes your kernel under heavy load or
other versions of LVM are on-disk incompatible. These are the reasons why we did
not enable it in the kernel we shipped.

You don't have to like that. Customers expect us to ship a stable kernel, and
the only way we can do that is to not enable every new experimental/unfinished
feature a kernel might have.

Note You need to log in before you can comment on or make changes to this bug.