Bug 383441 - netconfig is removed rather than fixed with update 1
netconfig is removed rather than fixed with update 1
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-network (Show other bugs)
5.1
All Linux
low Severity low
: ---
: ---
Assigned To: Harald Hoyer
qe-baseos-daemons
:
Depends On:
Blocks: 1049888
  Show dependency treegraph
 
Reported: 2007-11-14 16:08 EST by Jim Perrin
Modified: 2014-02-04 10:02 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-31 08:18:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Perrin 2007-11-14 16:08:58 EST
Description of problem:
netconfig is removed by the install of system-config-network 

Version-Release number of selected component (if applicable):
RHEL 5 update 1

How reproducible:
Always

Steps to Reproduce:
1. Use netconfig in 5.0
2. Update to 5.1 with system-config-network installed
3. note that netconfig is gone.
  
Actual results:
netconfig is gone, removed by the updated system-config-network because it no
longer works with pump.

Expected results:

netconfig should be updated so that it no longer requires/uses pump. 

Additional info:

This seems to be a mid-release breakage, as I do not want to use
system-config-network, I want to script cli updates to the network with netconfig. 

Fixing a utility which many use would make more sense than removing it.
Comment 1 Fabio Olive Leite 2008-01-03 08:31:45 EST
Re-assigning to component owner...
Comment 3 Harald Hoyer 2008-05-05 08:55:56 EDT
FYI, scripting can also be done with system-config-network-cmd 
Comment 4 Jim Perrin 2008-05-05 09:36:29 EDT
Yes, however system-config-network-cmd has a distinct and abysmal lack of
documentation. There's no manpage, there's no /usr/share/doc/ files, nothing. If
you're going to recommend it for scripting, providing some documentation within
the package would be helpful. Not trying to slam you for pointing something out,
because you are absolutely correct, just saying that the package is not yet a
suitable replacement for netconfig.

The only thing that works for system-config-netork-cmd is  --help, which leaves
a bit to be desired for clarity.  
Comment 5 Scott Dahl 2008-06-09 14:41:16 EDT
yes - we are hosed by this too.  We use the netconfig command for our
automated kickstart post-install scripts.  Is there something that can 
do the equiv of this now? 


/usr/sbin/netconfig --device=eth0 --domain=blarg.com --hostname=${HOSTNAME}
--ip=${MYIP} --nameserver=192.0.0.1 --netmask=${M
YNETMASK} --gateway=${MYGATEWAY}
Comment 6 Shekhar Joshi 2008-06-11 08:07:07 EDT
Since netconfig has been removed, it also means rc.sysinit and sys-unconfig
needs to be fixed. This needs to be done as on executing sys-unconfig,
rc.sysinit still calls netconf and not system-config-network-tui.

Also my guess is system-config-network-xxx.rpm is not part of the base (minimal)
OS install.
Comment 7 Chris Tracy 2008-06-13 18:18:48 EDT
Just ran into this issue migrating my 5.0 kickstart config to 5.1.  In response
to comment #5, the solution I used was:

TEMPFILE=`mktemp`
system-config-network-cmd -e -d | sed 's|BootProto=dhcp|BootProto=none|' \
         > $TEMPFILE
echo "DeviceList.Ethernet.eth0.Netmask=${MASK}" >> $TEMPFILE
echo "DeviceList.Ethernet.eth0.IP=${IP}" >> $TEMPFILE
echo "DeviceList.Ethernet.eth0.Gateway=${GW}" >> $TEMPFILE
system-config-network-cmd -i -d -f $TEMPFILE
rm -f $TEMPFILE

which replaced this call to netconfig:

netconfig --bootproto=none --gateway=${GW} --ip=${IP} --netmask=${MASK}

Comment 8 Scott Dahl 2008-06-13 18:23:47 EDT
thanks Chris - I will try that and comment back to this thread...
Comment 9 Jim Perrin 2008-06-14 08:40:45 EDT
It's a bit sad that a 1 line solution which worked had to be replaced by an 8
line script which uses a mostly undocumented command like system-config-network-cmd

Note You need to log in before you can comment on or make changes to this bug.