Bug 383511 - Intersil Prism 2.5 wlan not configured correctly
Intersil Prism 2.5 wlan not configured correctly
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-14 16:46 EST by birger
Modified: 2008-04-22 18:39 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.5.5-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-22 18:39:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description birger 2007-11-14 16:46:37 EST
Description of problem:
NetworkManager lists my Prism 2.5 wlan controller, and tags it as 'wireless',
but doesn't configure it correctly

Version-Release number of selected component (if applicable):
fedora 8

How reproducible:
I have tried deleting and adding the device, and it still fails

Steps to Reproduce:
1.
2.
3.
  
Actual results:
The device gets configured by default as eth0 instead of wlan0 as I would have
expected. When the system tries to bring the interface up it complains about
'link down' as if it was a disconnected wired ethernet.

Expected results:
a working wlan0

Additional info:
lspci lists it as
02:0d.0 Network controller: Intersil Corporation Prism 2.5 Wavelan chipset (rev 01)
Comment 1 Dan Williams 2007-11-15 14:59:04 EST
-> s-c-n
Comment 2 Harald Hoyer 2008-03-31 06:23:30 EDT
How do your /etc/sysconfig/network-scripts/ifcfg-* files look like?
Comment 3 Fedora Update System 2008-04-07 10:34:37 EDT
system-config-network-1.5.5-1.fc8 has been submitted as an update for Fedora 8
Comment 4 birger 2008-04-07 19:13:44 EDT
With recent updates I removed all network interfaces and rebooted.
The results were encouraging, with the interface now appearing as wlan0, but I
have yet to make it actually work.

I discovered that I had both orinoco_pci and hostap_pci loaded. I have tried
blacklisting one or the other, and with only hostap_pci I get wifi0 instead of
wlan0. Still the same result.

Status right now is that iwconfig lists wifi0 or wlan0 as a wireless device, but
iwlist <device> scanning doesn't find anything.

At least it's not a s-c-n issue anymore so this case can be closed, and I'll ask
for help on the hostap mailing list.
Comment 5 Fedora Update System 2008-04-22 18:38:43 EDT
system-config-network-1.5.5-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.